Skip to Content
0
Former Member
Apr 04, 2011 at 12:58 PM

Invalid MII version, PCo 2.1 Error with OSI Pi

61 Views

Here is my customer's setup.

MII 12.1.5

PCo 2.1.4

Pi 3.3.3.0

MII Connection in PCo is set to 12.1

Every once in a while they are getting am getting the following error

Error,xMIIMessageHandler,Unknown error.,"[severity = Fatal] Invalid MII version

at SAP.Manufacturing.Connectivity.MIIDestination.ExecuteUrlPost(String currentUrl, String content, Boolean loggingIn, Boolean useTextXmlContentType)

at SAP.Manufacturing.Connectivity.MIIDestination.XMIIPingTimerCallback(Object state)"

When this happens, the Agent instance stops and manually has to be restarted. It also seems to affect every Agent I have set up on this PCo. (I have seperate Agents, one dedicated for MII queries, another dedicated to notifications.

This error occurs sporadically with no warning.