Skip to Content

Couldn't able to do Text search with in Original

Dear Friends,

I Coouldn't able to do Text search with in Original. I did the following things in the system.

Installed RFC connection of TREX server & SAP R/3 in the following :

1.Entered Transaction SRMO to open search server relation monitor.

2.Clicked on button Create SSR. It will popup a window for u201CCreate Search Server Relationu201D. Now, in the field u201CSearch server relation IDu201D, entered GCDSEARCH.

3.Now clicked on button Create SSR.

4.In the field Search engine, select the Search engine DRFUZZY from the F4 help.

5.Enter the name of the RFC destination for TREX Server and click on Save.

Done Web server & TREX Server thru HTTP in the following manner:

1.Go to SKPR07 in tools tab select "DMS_PCD1" in document class field & docarea field with DMS

2.go to edit in the same Tcode and select Administration, you get popup screen fill Management table field with "DMS1DISTA"

3.Tick "Create indexing readiness" and "indexability of the class" options.

4.Click on "Index able Attributes" you get the sub-screen select all or required once.

5.Select in Customizing of Document Management the MIME types that you want to be read for the full text search; under General Data  Settings for storage systems  Create MIME types for full text search

6.There are two ways of scheduling indexing jobs, ABAP Program is "RSTIRIDX" Tcode SM36

7.after selecting in the TCode SM36 click on "job wizard" icon.

8.Schedule the full text search for cyclical background preparation.

Execute transaction Start job (transaction code SM36).

Schedule the job for the following ABAP program: RSTIRIDX (Report for indexing stored documents).

Here it is sometimes showing zero seconds to process & some time only 2 or 1 doc. In Development system I try to run on foreground also. I donu2019t know this is correct or not.

How many times we need to run this in back ground, is it one time activity or periodically need to be done. I did this in immediate mode.

9.In SKPR07 transaction When clicked on Test Indexing , It showed done successfully.

In CV04N u201CText search with in Originalu201D is showing.

When I am searching with various options it is showing nothing.

I tried for contents in Word document and PDF documents. I donu2019t know where I went wrong.

Is there any document available for complete this Customization & testing etc.. for TREX. I tried SAP help & SDN threads. Based on this I could do above customization.

I also want to know different types of searches like .

a.Linguistic Search

b.Fuzzy Search

c.Search by natural language

d.Word Search

e.Soundex

f.Class Features

g.Class

h.Exact Search

Regards,

Sai Krishna

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Apr 19, 2011 at 06:49 PM

    Hi Sai-

    I too am having problems getting this to work. I believe I have successfully indexed several documents, but when searching, my results aren't what I expect.

    If I put an * in the text search field of CV04N, I get a list of documents. Maybe try that and see if any of your documents have been successfully indexed.

    Do you get any results when you enter a * ?

    If so, maybe it is the version of MS-Office and Adobe you are using? Here is a link I found for the supported versions:

    http://help.sap.com/saphelp_nw70/helpdata/en/55/cb634114b78047e10000000a1550b0/content.htm

    Also, could search on TREX server for the file: TREXValidMimeTypes.ini - ensure that MS-Word and PDF are included. (But I think they are.) I am trying to have it work with just .txt files created from Notepad for now.

    Maybe we could work to together to get this working? I am now trying how to figure out how to get the delta indexing to work. That doesn't seem to work at all for me. (I thought because the green light for "automatic indexing" was turned on in SKPR07, it would index documents as they were checked in.

    Hope it helps.

    BR-

    -J

    Edited by: Jennifer Kramer on Apr 19, 2011 9:20 PM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 21, 2011 at 07:00 AM

    Hi,

    Please refer to the below thread.

    searching-of-document-based-on-title-of-original

    There are some notes related to TREX available in service market place. Please verify it.

    Regards

    Keerthi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.