Skip to Content
0
Former Member
Apr 01, 2011 at 12:41 PM

Typical Problem with the RFC look up !

22 Views

Hi Experts,

I am using a RFC look up to fetch data from on eof the tables in PI ( abap) stack .

The FM is commonly used standard FM: RFC_READ_TABLE. Its not the first time I am using it in my graphical mapping ,and it has worked really gud for me

But now I am facing a problem , Irrespective of what table I use it for for fetching data it is extracting data in a strange manner.

It IS fetching the data but in the following format, when I am testing the queue in message mapping.

rfclookup:out0

cC - in light grey

[] - in white

[] - light grey

[ADP] - white actual value that the RFC has extracted

[ADP] - dark grey

I have tried several permutation combination putting remove context , sort , but I cannot get rid of the -cC_ . Can any one pls tell me why is this happing.

I have used the same FM in other projects several times , never faced the same problem

Tried handling it in a UDF, but still cant get rid of it ,,,,, it is NOT allowing the [ADP] value to come as output.

I have tried with many other standard and z tables also . I have reimported the RFC. I have also imported the RFC from diferent server, but same issue is coming again and again

Initially it looked very ordinary context issue , but now it is really getting tough .

Experts , Please suggest.

Regards,

Arnab,