Skip to Content
0

PI 7.3 - RFC User does not log off

Dec 13, 2016 at 08:41 AM

114

avatar image
Former Member

Hello,

we are on SAP PI 7.3 SP 14 (SAPKB73014). There is a connection via interfaces to a SAP ERP System (SAPKB74009). In SM04 of this ERP system we state that PI-RFC-User does not log off. There are a lot of sessions still existing after interface working ended. Users do not log off.

Before the update to SP14 on SAP PI we had the workaround to open and stop an interface which is normally not used. This did a kind of "reorganization", users were logged off. After the update this workaround does not work anymore and problem still exists. At the moment I'm logging off the users manually after a few days. There is a maximum session number - if it's reached no more logins are possible.

The connections have this additional info in SM04:

R=4 T=S S=sapsid I=SAPJCo730 F=SYSTEM_RESET_RFC_SERVER C= U=

(where 'sapsid' is the hostname of the source system PI).

I'm not able to find any hints of help to change this scenario. Somewhere there has to be a wrong configuration, but I'm not sure if it's in interface configuration or in some basis profile parameters. I'm not very familiar with interface configuration.

So did anybody faced this problem too? How can we solve these persisting SM04-logins? Any ideas?

Regards,
Julia

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Shahid Ahmed Khadri Dec 13, 2016 at 08:51 AM
0

Hi Julia,

Where is this RFC user used? You mentioned that after stopping the interface, users were disappearing, which adapter interface is that?

Regards,

Shahid

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Dec 19, 2016 at 06:21 AM
0

Hello Shahid,

the workaround before the update to sps 14 was to restart a communication channel. This was not a specified communication channnel. Regardless of which communication channel was restartet, the users disappeard. But: this was before update to sps 14.

Now this workaround does not work anymore. Users disappear, if system is restarted. Or if I delete them in SM04.

Regards,
Julia

Share
10 |10000 characters needed characters left characters exceeded