Skip to Content
0

cluster error in smart data streaming

Dec 13, 2016 at 06:36 AM

158

avatar image

Hi Jeff Wootton,

I am facing the similar issue Cluster error.
I followed the path to see the trace.
Could you please let me know how to resolve this issue.
In the Data Services view i am creating new Workspace and adding a new service and creating my data streaming project in Project Explorer

I am implementing streaming projevt from the below link.

http://www.sap.com/germany/developer/tutorials/sds-part1-configure-streaming-server.html

I am able to compile the streaming project successfully,but when am trying to execute the streaming project it is throwing cluster error.

Could anybody please help me to solve my issue.

Regards,
Shekar

10 |10000 characters needed characters left characters exceeded

You haven't given us the error you are getting in Studio, any output from the Console log in Studio or any info from the output or trace files. We will need those details in order to provide any meaningful feedback.

0
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Mantri Shekar Dec 14, 2016 at 05:20 AM
0

Hi Robert Waywell,

Please find the attached error screen shot and text file which consists of trace log.

Please help me to resolve this issue.

new-text-document-2.txt


Share
10 |10000 characters needed characters left characters exceeded
Robert Waywell
Dec 14, 2016 at 03:19 PM
0

Based on the trace file output, the "hanadb" data service doesn't exist:

[1130]{-1}[-1/-1] 2016-12-08 11:52:48.177000 e Streaming UNKNOWN(-0001) : [SP-3-100005] (0.270) sp(1130) Error creating database connection. Service hanadb does not exist.

You're original post mentioned creating the service. A couple of things to check are the spelling of the service name and to verify that you can run "Discover" on the service to discover the schema and tables that you are referencing in your project.

Since the error message states that the "Service hanadb does not exist.", this most likely an issue with the service either not existing at all or having a different name. In contrast if the issue was with the user ID or password then I would expect to see an authentication error as opposed to a "... does not exist." error.

Share
10 |10000 characters needed characters left characters exceeded
Mantri Shekar Dec 15, 2016 at 06:47 AM
0

Hi Robert Waywell,

I am using HANA SPS 11 which is hosted on AWS. Is this creating any issue.

In SAP HANA Streaming Development Perspective i created a workspace named 'valuefact' and in that am creating s service with name 'demo'

After that i right clicked on Schema and Tables then am getting all the schemas available .

Could you please let me know am i making any mistake here.

While defining Server connection in server view in host name am giving the host name of hana db server.But actually i should not give this.

But am unable to find the streaming server hostname.Could you please let me know how to find the streaming server hostname.


Share
10 |10000 characters needed characters left characters exceeded
Robert Waywell
Dec 15, 2016 at 02:26 PM
0

Ok, you have named your dataservice "demo", but somewhere in your project you have an element that is looking for a dataservice called "hanadb". The easiest way to find that would be to go to the SAP HANA Streaming Development perspective in HANA Studio, open your project .ccl file in the text editor (or use F6 to switch from the visual editor to the text editor) and then go to Edit -> Find and search for "hanadb".

Share
10 |10000 characters needed characters left characters exceeded
Mantri Shekar Dec 16, 2016 at 10:34 AM
0

Hi Robert Waywell,

I changed as you suggested but still it is throwing the same error.

Is there any other way where i can resolve this issue

Show 1 Share
10 |10000 characters needed characters left characters exceeded

What do the project log & trace files show now? What does the server log show?

0