Skip to Content
author's profile photo Former Member
Former Member

inboun idoc error in sap r/3 from PI

Hi all,

I am having problem in posting an idoc of type cond_A01, i am getting an error 51: Application document not posted, with a message: Table TA91 does not exist. When i checked for table TA91 it is not there, and when i checked A911 it is there. So i need to change, so that it checks for table A911 instead of TA91. when i am sending it from pi it was showing that A911 in mapping, but in r/3 is not updated. Can you please help me in this.

1:) Where do i need to make changes?

2:) Do i need to change in Process code( COND is the process code for cond_A01?) .

3:) Is this a PI issue or ABAP issue.

Thanks.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 29, 2011 at 03:57 AM

    Hi,

    Table starting with T are standard tables and entries in that get populated automatically based on the operation of application...

    so in your case you dont need to do any thing either in PI or in ABAP check with the SD consultant they will be able to give you the exact root cause for the error....

    this error is related to confiuration settings of R/3..so check with functional consultant..

    HTH

    Rajesh

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 23, 2011 at 07:31 PM

    Hi cnu,

    Check in the mapping, if you are passing any value 'T091' and if yes, change it to the correct table name .

    If you are sure that you are not passing T091, then its an backend (ABAP) issue and someone from ABAp team needs to debug the inbound processing function module.

    Best Regards,

    Ravikanth Talagana

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      This seems to be an ABAP issue.

      There is no need to make any changes on PI side.

      Make sure the metadata of the Idoc is updated in PI.

      Also try to reimport the Idoc structure into PI, if there are any changes.

      Regards,

      Subbu

  • author's profile photo Former Member
    Former Member
    Posted on Apr 07, 2011 at 08:41 PM

    Hi Rajesh,

    I my case your are right.....we found the issue, it is data problem.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Gud poeple

      My Scenario is MDM to ECC

      I am facing the very similar error on my interfaces, I am creating to IDocs MATMAS and CLFMAS

      the status is 51 and the error is :

      -- Object 0008341 from table MARA has not yet been created. For this reason, no class allocations can be maintained for this object.

      When trying to process the CLFMAS IDoc for Materials

      What could be the problem.

      Thanks,

      Yonela

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.