Skip to Content
Former Member
Mar 17, 2011 at 11:25 PM

Visual Studio 2010 Upgrade - Record Selection Formula not being applied


I converted a Windows application that had been developed in VS2005 so that it would run in VS2010. The application contains several Crystal Reports.

What I am finding is that when the reports are run, the parameters window pops up requiring the user to specify the desired parameter values, and after the user does that and clicks OK, the report comes up ignoring the parameter values that pertain to record selection in the report.

For example, the user is asked to choose the invoice type to be displayed. But even if type 1 is chosen, all the types are displayed. I can display the actual type number, eg. 1 in the report, so I know the report is aware of what has been chosen. I can hardcode the choice in the Record Selection Formula, eg, instead of {spNewClientsInvoices;1.InvoiceTypeID} in {?InvoiceTypes} where {?InvoiceTypes} are the invoice types chosen, I can put {spNewClientsInvoices;1.InvoiceTypeID} = 1 and still get all the records, regardless of the their invoice type, appearing.

All the existing reports using record selection, that worked fine with VS2005, have this problem. I have not created a new report to see if the problem occurs in that situation as well.