Skip to Content
avatar image
Former Member

application fails unless ran as an administrator, PB 11.5 and 12.6

We have an application, Powerbuilder 11.5, that is failing at the customer site. We upgraded to PB 12.6 build 4098. Both versions have the same issue. Data is returned to a DataWindow. Once the data is returned to the window, it can be sorted. We then add a blank row to the datawindow, no database transactions at this point. As soon as we click the cursor into any row of the new row, the application hangs and never gives us control back.

I looked around for accessibility issue, and found KBA 2288878. It seems similar to what we are having, but I cannot verify it yet. The resolution they show is not an option for us since our application has to be 508 compliant.

So, we stumbled across ways to get it to run temporarily. If we start the application and get to the point where it hangs, we leave that application hung up and start another application and login and it works great. As long as we have one hung up, the second iteration of it works correctly. We can also right click the application exe and 'run as admin' and it will work also. But, regular users cannot 'run as admin', so that is not a solution.

I filed a trouble ticked with SAP only to be told they suggest running all applications as 'admin'.???? And then to turn off accessibility, which we cannot do. So, no help there.

I have not been able to reproduce the problem at this point, but multiple machines at the customer site are failing.

Any ideas ways to diagnose what is causing this problem?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers