Skip to Content
avatar image
Former Member

Need to install the .Net Connector DLLs on the server ?

Hello,

I developped a .net c# service that connects to SAP via the SAP .Net Connector 3.0.

I added the dll in "reference" in my service project with copy local = true.

I installed my service on our .net application server and started the service.

When calling method of the service, I receive the following error (note that the dll's are in the application folder)

System.Exception: Configuration Load Error :

System.TypeInitializationException: The type initializer for 'SAP.Middleware.Connector.RfcConfigParameters' threw an exception. ---> System.IO.FileLoadException: Could not load file or assembly 'sapnco_utils, Version=3.0.0.42, Culture=neutral, PublicKeyToken=50436dca5c7f7d23' or one of its dependencies. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

File name: 'sapnco_utils, Version=3.0.0.42, Culture=neutral, PublicKeyToken=50436dca5c7f7d23' ---> System.Runtime.InteropServices.COMException (0x800736B1): This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. (Exception from HRESULT: 0x800736B1)

Searching, I just tried by installing the .Net Connector 3 on the server.

After this, my service works fine.

So I thought to remove the dll in the folder of my application.

By doing this, I receive the same error as above (note that the .net connector is installed on the server)

So to resume, it seems that my service only run correctly when the .net connector is installed on the server AND the .Net DLL's (sapnco.dll and sapnco_utils.dll) are present in the folder of the service.

Can someone explain why it is so or what am I doing wrong ?

We never had this problem with old version of the SAP .Net Connector as having the dll in the application folder was sufficient.

Thanks in advance all for time and help

Denis Willems

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 15, 2011 at 03:51 PM

    Hi Denis,

    I just want to say that I've seen the same behaviour on my server, too.

    regards

    Daniel

    Add comment
    10|10000 characters needed characters exceeded