Skip to Content
author's profile photo Former Member
Former Member

Xcelsius 2008: Merge dimensions not updating when published as BI Services

Hi to all,

I'm designing a Customer Satisfaction Index dashboard in Xcelsius 2008 SP3 and using QaaWS as my main connection. My web service was a published block in rich client BI Services. Now in my block, I used merged dimensions with different prompt dates and set of questions. Itu2019s working fine when refreshing it in rich client but when I use it in my Xcelsius, only the first query was updating. Both queries are using u201CBETWEENu201D in the date prompts but one is for the service date and the other one was for the delivery date.

Itu2019s actually working when I tried separating and publishing both queries then use it as two separate connections in Xcelsius. Which means my login credentials, date format, etc. in Xcelsius are correct.

Are there any known explanations for this one? Does a merged dimension work in Xcelsius QaaWS?

Thank you and appreciate if someone can reply ASAP 😊

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Mar 13, 2011 at 01:33 PM

    What is the exact veriosn and patch level of your BO server?

    Regards,

    Stratos

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 14, 2011 at 05:22 AM

    Hi Stratos,

    Our BO is version 12.3.4 build 895.

    Thanks,

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 14, 2011 at 11:14 AM

    Yes the queries are updating as expected if I run the report in rich client. But once I publish the table and use it in Xcelsius, it's not updating anymore. I even tried testing the web service in rich client and same thing, it's not updating. In my table/block, i have the following columns:

    Region, Center, Service, Sales

    The region and centers are merged dimensions while service and sales uses different questions / calculations. Also, the date prompts in Service uses service date while Sales uses sales date.

    If I separate and publish the two as web services, everything is working fine. 😔

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 07, 2011 at 07:30 PM

    Hi,

    If you use the Efashion Universe even you can reproduce the exact same problem.

    I opened up a case with SAP and it looks like indeed it is a bug.

    Hopefully they will fix it soon as the merge is an important feature.

    One work around that I found works is if you use the same prompts in both queries. Let me know if that helps.

    Regards

    David

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.