Skip to Content
avatar image
Former Member

Tag not visible in xml file after syndication

Dear Experts,

We have recently upgraded our Dev & Quality system to 7.1 SP6 from 5.5 SP6...(PRD is still yet to get upgraded)

It is an issue regarding syndication.

After syndication when i compare 7.1 DEV/QAS(which are upgraded) with 5.5 PRD xml file, after opening the respective xml file i see the 3 of my tags are not visible in the xml file as compare it to PRD (5.5)xml file.( inspite of null value, it still shows only the tag in xml file )

But, at the same time if in QAS / DEV(upgraded) , when i fill the values in these 3 tags , it is reflecting in xml file just like PRD.

Now,how do i make those 3 tags visible in DEV & QAS syndication xml file ,even if it has a null value.

Is there any settings which i need to check in syndication map or in MDSS.ini file? or does PI can do some settings to resolve this issue ? and what can be the solution from PI side?

Please suggest !!

Thanks in advance

Regards,

Harmony

Edited by: harmony_2303 on Mar 10, 2011 11:42 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 10, 2011 at 11:47 AM

    Basically you can not set the required option in the syndicator. This need to be done within the schema file

    You need to open the XSD in some editor (some xml editor, or just a text editor) and make the fields mandatory over there, then import XSD back in Console and use in syndication map.

    Regards

    Henning

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 10, 2011 at 10:55 AM

    Hi Harmony,

    I am not fully sure I understand you question. But I have had a similar problem when upgrading from 7.1 SP05 to 7.1 SP06 regarding syndication maps and missing segments in the xml file.

    What I did to solve this was to add a static value in the SEGMENT field in those particular segments you miss in the xml file. This can be done simply by selecting the SEGMENT field in the segments that are missing and add a static value of 1. This also depends on whether this is required for you in the xml file but it was for me.

    Another option could be to use the required option for that segment which should print out the segment eventhough no values are present.

    I hopes it helps.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Hanning,

      I tried your solution , but it didn't helped.

      When i added value -1 under the respective segment static and tried syndicating one record with same.

      XML File - I could see the tag now but, the value is coming as "1" ( which is added in static segment)

      I noticed this field is not "Required" , when i am trying to mark it as "required " its not allowing me because its all grayed out.

      Please suggest !

      Regards,

      Harmony

  • avatar image
    Former Member
    Mar 10, 2011 at 11:55 AM

    For additional information:

    Maybe there is a line in there already otherwise you could add an attribute line, something like this:

    <xsd:attribute name="SEGMENT" type="xsd:string" use="required" fixed="1" />

    Regards

    Henning

    Add comment
    10|10000 characters needed characters exceeded