Skip to Content
avatar image
Former Member

Can not start JDBC Sender Communication Channel

Hi Guys,

Some very strange things is happenning in MY PI 7.1.

Normally, when I stop then start the corresponding JDBC Sender CC in the CC monitor, the CC will try to get data from the data source, and the message text such as '3/10/11 2:35:27 PM Processing started' will be shown there under the 'cluster node' tab, but there are 4 of the JDBC SENDER CCs do not work, which means when I stop and start the CC, there is no interaction and no message shown.

I have 2 other JDBC SENDER CCs connected to the same data source and they work well. I don't know why these 4 CCs can not be started.

I have tried to test the 4 CCs in my development enviroment using the same connection parameters, they works fine in the development environment.

it seems very strange,so could any guys tell me any possible reasons? thanks very much.

Dario.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Mar 10, 2011 at 06:43 AM

    Hi,

    just a check, Open any of the sender JDBC in ID and go to change mode, and in description add a space, and save ,activate.

    Clear SLD Cache and restart the Communication channel in Communication channel monitoring. Before Doing change in JDBC adapter stop that channel in CC monitoring.

    Its funny but it works sometime. It happens coz of cache is not reflecting to the adapter. So small change and activation can refresh.

    Regards

    Aashish Sinha

    Edited by: Aashish Sinha on Mar 10, 2011 7:44 AM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      thanks for your reply.

      but it does not work, actually i have ever tried both the CPA cache refresh and restart the JDBC adapter, but the CC still can not be started.

      thanks.

      Dario

  • avatar image
    Former Member
    Mar 10, 2011 at 08:12 AM

    Hi,

    See Note 1483974 - File and JDBC sender adapter's retry not working after error

    REgards,

    Carme

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Dario,

      The reason why I pointed regarding the table is I have faced the same problem recently and struggled a lot to resolve this simple issue. the mistake I have done was I have opened the table in TOAD application and tried to poll the data from the table which I opened.

      The channel was in green- functioning and was unable to poll the data .

      Cheers!!!

      Naveen.

  • avatar image
    Former Member
    Mar 10, 2011 at 10:09 AM

    Hi ,

    What you can Do is check the following places...

    1. Check if Communication channel is not locked.

    29.How to delete manually hanging Enqueue-Locks

    Q: During the OOM error the J2ee engine goes down while the lock in the enqueue server still persists.When the channel comes back during restart as the effect of OOM error it will not able to get the cluster wide enqueue lock as the previous lock remains there in the enqueue server.How do I resolve this?

    A: The existing (hanging) enqueue server locks for the corresponding JDBC channels(JDBC Lock Arguments) can be deleted manually by following given below stated procedure:

    1. Stop the corresponding JDBC channels.

    2. Open Visual Administrator.

    3. Route to correspondig server.

    4. Expand services and go to Locking adapter.

    5. In the locking adapter service go to Display locks tab and

    click on refesh button then you will able to see the list

    of all the available locks.

    6. Select the existing (hanging) enqueue lock with JDBC Argument from the list.

    7. Click on "Delete Selected Locks" button.

    Follow the instructions and delete the lock related to the stopped communication channel. For the 7.1 versions, please note that the Lock Manager is under the /nwa/locks, or on the location "Availability and Performance Management -> Locks".

    2. Check if Query Written in Select at Sender Channel is working fine and picking up any data .

    Regards

    Prabhat Sharma.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I just deleted the scenario and create a scenario with new name, and finally i can see the message:

      3/11/11 10:51:50 PM 86935d10-943a-40f7-17db-be93ae61a03f Polling interval started. Length: 21600.0 seconds

      3/11/11 10:51:50 PM 86935d10-943a-40f7-17db-be93ae61a03f Processing finished successfully

      3/11/11 10:51:50 PM 86935d10-943a-40f7-17db-be93ae61a03f Message with ID 86935d10-943a-40f7-17db- be93ae61a03f processed

      3/11/11 10:50:12 PM Processing started

      it works!!

      the most important point is that I created the new scenario with different name,-

      thanks,everyone

      dario