Skip to Content
avatar image
Former Member

After restart have to re-publish pages?

Has anyone had this problem? After restarting our MII system, all server nodes are green/running but we get 404 html page not found error until we go in and republish pages manually. We are on 12.0.10.2 version in Windows SQL clustered environment.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 07, 2011 at 10:02 PM

    Have you looked at the NetWeaver logs to see if any relevant errors give any insight into the situation?

    The file system may also be a good indication. Consider the following example paths for 2 server nodes (bolded area):

    d:\sap\F12\JC30\j2ee\cluster\ server0 \apps\sap.com\xappsxmiiear\servlet_jsp\XMII\root\CM

    d:\sap\F12\JC30\j2ee\cluster\ server1 \apps\sap.com\xappsxmiiear\servlet_jsp\XMII\root\CM

    Do you see fresh files in one of the two locations but not the other?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Finally got a chance to restart the servers this weekend to check this out. First, both N1 and N2 were stopped.

      After restarting N1 (primary server), only the first 8 of 30 folders showed in the ...\j2ee\cluster\ server0 \apps\sap.com\xappsxmiiear\servlet_jsp\XMII\root\CM location. All server nodes showed the same 8 folders and in all server nodes the date/time stamp was current. When I went into MII workbench and republished another folder, it would show up in all server nodes immediately with current date/time. My question here is why don't all 30 folders publish on restart?

      Now here's the other oddity. I then started N2 server and checked the same file location. On this server it showed ALL the folders but with an older date/time stamp (about a week ago). I then restarted N2 again and now the file location showed only the 8 folders.

      Any ideas?