Skip to Content

input history in sap gui

Hi,

How can I disable input history in sap GUI?

I tried control+right click to get the context menu enable/disable input history, but unfortunately I am not able to find the context menu on right click.

Is there a possibility of context menu not being enabled for a particular user, if yes, where I can check it? Or is it some version issue? I m using sap gui7.3.

I know the option to disable it in the data element. I want to know how to disable it for this particular screen. For ex: SE38->Program name field, I want to disable the I/p history.

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    Posted on Dec 14, 2016 at 01:18 PM

    Hello Jaya

    You have the possibility to disable the history via the screen painter
    (Note 1099850).

    Best Regards,

    Jude

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 12, 2016 at 11:07 AM

    You need at least SAPGUI 640, patch 13.

    You could ask basis to build some script/reg file for mass update as this can be done in regedit: (same as manually done thru SAP GUI options, local data, history)

    HKEY_LOCAL_MACHINE (or HKEY_CURRENT_USER)
      SOFTWARE
        SAP
          SAPGUI Front
            SAP Frontend Server
              LocalData 
         (new) String name: Exception1 " , 2, 3, 4, etc.
               Contents   : STRUCTURE-FIELD " field name in dynpro

    Else there is a (less recommended by SAP?) Abap option with class-method CL_GUI_FRONTEND_SERVICES=>DISABLEHISTORYFORFIELD.

    Regards,
    Raymond

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 13, 2016 at 05:29 AM

    Thanks for ur inputs...

    But my question is to disable I/p history for a field on a particular screen. I have read like cntrl+right click will give u a context menu where u can enable or disable the input history for the field on the screen. This context menu is not available for me. I am trying to find the reason for it. (If we goto se38, in the program name field usually have the I/p history. I want to disable it)

    I guess the setting u all r referring to is options->Local data->History OFF.

    If I turn the history OFF , it will not save I/n history for any fields rit?

    I want to know why the context menu->enable/disable is not available for me.

    As mentioned by Raymond , my version seems to be ok. Then is it around some authorization issue?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 15, 2016 at 06:42 AM

    Jaya,

    May I know why do you want to disable that feature which is considered as a Plus to the end User,while filling the data.

    K.Kiran.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 16, 2016 at 10:52 AM

    For security reasons, eg: for entering personal or fininacial data.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 12, 2016 at 05:23 PM
    -2

    hi varghesh,

    It's possible to disable by using default sap settings .

    Regards,

    Raja

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.