Skip to Content
author's profile photo Former Member
Former Member

SSO to ITS via EP6

Ok all knowing people, I have this working in EP5 but, can't get it working in EP6.

Our Portal:

EP6 SP2 Pack3 Hotfix7. Working like a champ. However, SSO to our ITS box will not work.

I have downloaded and am using the SAP application integrator. After creating the ITS System I make an Iview with com.sap.portal.appintergrator.sap with the generic component selection.

Url template is HTTPS://its.server.net/scripts/wgate/webgui/! ?

Template fraction for user mapping:

login=<mappeduser>&password=<mappedpassword>

After I run the Iview I get a runtime error.

"Unable to process template https://its.server.net/scripts/wgate/webgui/! ? because authentication is an invalid terminal property of the context."

Am I going in the wrong direction? Do you know of anyone that is running a webgui within an Iview with SSO?

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on May 09, 2005 at 10:09 PM

    For those of you having problems with SSO to ITS via EP6, there is a bug if your portal is at SP10. See recently released SAP Note 828552. A code fix is attached to the note.

    - Mike

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 01, 2004 at 12:31 PM

    David -

    Is there a reason why you are using the application integrator? You should create a system in the portal for the SAP system to which you are connecting. In the properties, you specify the ITS protocol, server, etc.

    Next you should create an iView that uses the previously defined SAP system.

    Regards,

    Kyle

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.