Skip to Content

NodeInfo(LogQuestCust.X) ): structure field Add_Documents not found

Hy All,

after reimport of the model and some changes in the CustomController, I got an error message with the text:

"com.sap.tc.webdynpro.progmodel.context.ContextConfigurationException: NodeInfo(LogQuestCust.X): structure field Add_Documents not found

at com.sap.tc.webdynpro.progmodel.context.AttributeInfo.init(AttributeInfo.java:446)

at com.sap.tc.webdynpro.progmodel.context.NodeInfo.initAttributes(NodeInfo.java:692)

at com.sap.tc.webdynpro.progmodel.context.NodeInfo.init(NodeInfo.java:677)

at com.sap.tc.webdynpro.progmodel.context.NodeInfo.init(NodeInfo.java:682)

at com.sap.tc.webdynpro.progmodel.context.NodeInfo.init(NodeInfo.java:682)

at com.sap.tc.webdynpro.progmodel.context.NodeInfo.init(NodeInfo.java:682)

at com.sap.tc.webdynpro.progmodel.context.Context.init(Context.java:38)

at com.sap.tc.webdynpro.progmodel.controller.Controller.init(Controller.java:199)

I have looked at the model binding of the controller.

I have looked at the context mapping of the WD View.

I can't find the errror !

Thanks for Help !

By Jürgen Berndt

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 26, 2004 at 04:02 PM

    Hi Jurgen

    I believe this problem comes due to the refresh of the model object.

    Try doing this.

    1. Close your webdybpro.

    2. Undeploy the project from SDM. This can be done using the remotegui.bat (\usr\sap\J2E\JC00\SDM\program).

    3.Restart the application server

    4. Redeploy the project using NWDS.

    Hope this should solve your problem

    Regards

    NagaKishore V

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 27, 2004 at 04:36 AM

    Hi Jürgen,

    if you import a model, there are often some structures generated, which you can see at "Dictionaries->Local Dictionary->Data Types->Structures".

    If you bind context model nodes to models, the corresponding structures are automatically used to determine the simple types of the node's attributes.

    If you reimport the model and the corresponding interface was changed, maybe renaming Add_Documents to Add_DocumentsX, the structure attribute which were used for the initial binding, doesn't exist any longer. Then you should get an error in the Tasks view of the NWDS about the missing structure attribute. Isn't that the case?

    Please recheck the context nodes of the controller, which are bound to the model. Missing attributes should be marked by a red cross. If you rebind the model, build and deploy, it should work.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 27, 2004 at 07:32 AM

    Hi Jürgen

    Since you got this over after a reimport , remapping and deployment . I guess a simple restart of the server process should refresh your models and remove the error.

    Works for me 😉

    Regards

    Pran

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jürgen Berndt

      Hi Jürgen,

      I am also facing tha same problem of strucutre field not found.

      i made changes in table.so i reimported,reloaded the project also.but still .

      As u said u r problem was solved i u r last post reg the same.

      can u just say how?is it by restarting the J2EE Server.

      its peak time for me.Expecting u suggestion ASAP.

      Thanks in Advance

      salini