Skip to Content

sap queue high volume


For handling the huge size message in separate queues I configured to use separate queue.

With the help of this document.

my high volume messages are going in XBTL, but when multiple messages came with high volume then it is waiting for XBTL00 queue only, this queue is not increasing the number as XBTL01, XBTL02 , etc.

How to set up to increase the queue number when we receive multiple high volume messages?



Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Dec 11, 2016 at 06:28 PM

    Hello Khaja,

    Parallelism of large messages processing in Integration Engine can be tuned by setting custom value for parameter EO_MSG_SIZE_LIMIT_PARALLEL (group TUNING) in tx. SXMS_IECONF / SXMB_ADM > Integration Engine Configuration. Default value of this parameter is '1', which means parallel processing for large messages is disabled and all large messages are processed within a single qRFC queue. You may want to increase its value in order to enable parallelization, but please make this change carefully - inadequately high parallelism in processing large messages may cause performance and stability issues. Following SAP general recommendations, it is not advisable to set value of this parameter higher than 2-3 due to performance considerations.



    Add comment
    10|10000 characters needed characters exceeded