Skip to Content

WEBGUI Timeout immediately after logging in

As soon as I log into webgui, i get the message "The session terminated due to inactivity". I have set the http and https timeout to a high value, but it's still timing out immediately. I have recycled the system, any ideals.

icm/server_port_0 PROT=HTTP,PORT=80$$,TIMEOUT=300,PROCTIMEOUT=3000

icm/server_port_2 PROT=HTTPS,PORT=8444,TIMEOUT=3000,PROCTIMEOUT=6000

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • avatar image
    Former Member
    Apr 26, 2011 at 06:05 PM

    I have the same problem in NW 7.02 SP06 environment ( kernel 80 ) . Any fixes would be appreciated .

    Thanks

    Gopal

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I've resolved the issue . The 'ITS.SAR' file did not extract to DIR_DATA/icmandir automatically . So I had to this manually to fix the issue ..

      1.Stop SAP and clean process/memory

      2.Rename 'its' directory in DIR_DATA/icmandir

      3.Extract 'ITS'SAR' from exe directory into DIR_DATA/icmandi

      4.Start SAP

      It's should work fine now . This resolved two issues . 1 . Immediate timeout in ITS transaction 2. DSM:XHR error which existed even after applying NWBC patch13.

      Gopal

  • Feb 17, 2011 at 07:09 PM

    this is for SAP Netweaver 7.00 EH2 install.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 17, 2011 at 07:09 PM

    this is for SAP Netweaver 7.00 EH2 install.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello David,

      Could you please activate some of the other ITS Services and test if the issue also occurs with those?

      If NOT, then it is the configuration of the Webgui service itself so check the configuration in SICF.

      Edgar

  • avatar image
    Former Member
    Feb 25, 2011 at 01:54 PM

    Hi David,

    Iu2019m in the same trouble as you (with NW 7.02 SP6).

    When I perform an ITS test connection I reach same session terminated message.

    But I can test successfully any iview which launch SAP transaction.

    I check webgui service ; very few parameters :

    ~webgui 1

    ~theme sap_tradeshow_plus

    ~xsrfcheck 1

    I check note 1481392 for xsrfcheck parameter (and I try to set unsuccessfully parameter ~xsrfcheck to 0

    I you find any solution, it will interest me !

    Alain

    Add comment
    10|10000 characters needed characters exceeded

    • Try updating to the latest kernel. I've seen older versions of the Kernel in which this happens.

      It seems it is somehow related to the file ITS.SAR not being able to update the directory in DATA/icmandir/its after kernel upgrade. When you upgrade the Kernel and the system restarts, this directory should have been deleted and replaced with the SAR's contents. And somehow, after upgrading the its folder gets its contents outdated.

      Take a look at the following folder:

      DATA/icmandir/its/lsgui/js

      If you are missing file sapItsSplitter.js, then you probably have a faulty installation of the latest Kernel.

      If this is the case, when you upgrade to the latest Kernel available in SMP, you'll automatically fix that issue after restarting.

      After applying the latest Kernel, check the file 'last_update_ITS.txt' under DATA/icmandir.

      This file should have a date compatible with kernel release date and upgrade date.

      If you still have any date older than those, then you are still using a faulty installation of ITS. Maybe permissions at that folder do not allow it to be updated during upgrade - who knows?

      It is also possible to force the its update to take place. To do that you have to rename the 'its' directory under DATA/icmandir to anything you which (instead of deleting it) and then restart the instance.

      This procedure will make the system unpack the ITS.SAR file from the Kernel again into the proper location - restoring a valid ITS directory.

      Hope this helps.

      BR,

      Ivan

  • Mar 05, 2012 at 07:56 PM

    problem was with the version of the kernel, we downgraded the kernel and it was working as designed.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 29, 2012 at 02:57 PM

    Please check note 1655770 

    Add comment
    10|10000 characters needed characters exceeded