Skip to Content
0
Former Member
Aug 17, 2004 at 07:38 PM

com.inqmy.services.rmi_p4.P4IOException connecting to J2EE Engine Admin

279 Views

After a successful default installation of WAS 6.20 (ABAP and Java Stack)on W2003 with IBM DB2 UDB 8.1 FixPack 5b and SAP J2EE Engine Patch Level 24, I can't login to the SAP J2EE Engine Administrator tool. At 10% the error message appears:

Login to localhost

com.inqmy.services.rmi_p4.P4IOException: Connection refused: Connect.

The login data is:

user: Administrator

psw: "" (empty)

server: localhost

port: 50004 (P4 port in standard installation)

The same error message occurs when connecting to the LogViewer:

javax.naming.NamingException: Connection refused: connect

ID003814 : JNDI Exception in GetInitialContext of InitialContextFactoryImpl. Root exception is com.inqmy.services.rmi_p4.P4IOException: Connection refused: connect

Using the command "telnet localhost 50008" results in:

Connecting To localhost...Could not open connection to the host, on port 50008:

Connect failed

On the server itself I login with the <sid>adm account, with local administrator privileges on the server and use port 50004 (default installation).

The SAP J2EE Engine Config Tool and the Deploy Tool seems to work fine.

The prepconf.log file in the D:\usr\sap\<SID>\DVEBMGS00\j2ee shows

-


Installation Target Directory = D:\usr/sap/<SID>/DVEBMGS00/j2ee

Java Home Directory = C:\jdk1.3.1_12

Port Base = 50000

Port Offset (by system number)= 0

-


http port = 50000

httptunneling port = 50001

jms port = 50002

http over ssl port = 50003

p4 port = 50004

p4 over http port = 50005

p4 over ssl port = 50006

iiop port = 50007

telnet port = 50008

monitor disp port = 50009

disp join port = 50010

disp open port = 50011

serv 0 join port = 50020

serv 0 open port = 50021

serv 0 monitor port= 50022

-


The p4 properties file in D:\usr\sap\<SID>\DVEBMGS00\j2ee\cluster\dispatcher\services\p4 shows:

port=50004

The security properties file in D:\usr\sap\<SID>\DVEBMGS00\j2ee\cluster\server\services\security shows:

userGuests.isUser=false

user1.password=

userGuests.password=

userAdmins.isUser=false

user3.name=System

ZipDirectory=logBackup

MaxUsersCount=1000

UnicodeLog=false

user3.isUser=true

user1.isUser=true

SessionExpirationPeriod=100000000

userAdmins.parentGroups=

user2.parentGroups=administrators

userAdmins.password=

forceCreateAllUserEntries=false

userGuests.name=guests

MaxFileLength=1048576

user2.password=

userAdmins.name=administrators

user2.isUser=true

user3.parentGroups=administrators

user1.name=Guest

user3.password=

user1.parentGroups=guests

CaseSensitive=true

user2.name=Administrator

userGuests.parentGroups=root

The version.txt shows:

Cluster-Version:6.20 PatchLevel 84596.20

Build java version:1.3.1_12-b03 Sun Microsystems Inc.

What can be the problem?