Skip to Content

Transport of WD4A Application/Component Customizing does not work

Hi Experts,

I tried to customize Application FITV_POWL_TRIPS to hide two tabs. I did this on a Test Machine Customizing Mandt (100) via SE80 --> Test Application --> entered parameter &sap-config-mode=x; then did my alterations and saved them into a transport. SE01 recorded the following:

R3TR | TDAT | WDY_CONF_USER

--> WDY_CONF_USER

In case I then test the application with different users, the changes work for them all (as it should be).

After transporting the changes via scc1 to another Test Machine Mandt (103) which is connected to our Test-EP, the changes are supposedly there (i checked via WD WD_ANALYZE_CONFIG_USER on both Mandts, they are identical) but when I test the application, the changes don't take effect on Mandt 103 😔

Shouldn't it be working like this or am I missing something?

best regards

Lukas

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Feb 14, 2011 at 11:52 AM

    Hi,

    If i read your post, i do not see any problem. I expect that to be working.

    Are you sure that everything is activated in client 103

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Lukas Weigelt

      Hi Lukas,

      I didnt think that only customization transport was transported. Normally people have to activate sicf services ,that was why i asked you to check if everything is activated.

  • avatar image
    Former Member
    Feb 15, 2011 at 06:21 AM

    Hi Lukas,

    I think FITV_POWL_TRIPS is a POWL based application. Then you might need to run the report POWL_D01 to clear the POWL cache. It might be the reason that the Application is showing you data from Cache, so you need to clear the cahce to let load everything including your customization.

    Please see this wiki for more details [POWL wiki|http://wiki.sdn.sap.com/wiki/display/WDABAP/POWL]

    Otherwise i don't see any problem in your implementation.

    Best Regards

    Vineet

    Add comment
    10|10000 characters needed characters exceeded

    • I activated/generated all Components as you suggested, no effect still.

      Took a look at wdy_conf_user... looks good as well..

      Mandant:  103                                                                                
      User:  *                                                                                
      User-Scope:  A                                                                                
      Config-ID:  FITV_POWL_TRAVELLER                                                                                
      Config-Type:  00                                                                                
      Config-Variant:                                                                                
      Config-View:                                                                                
      Component-Name:  POWL_UI_COMP                                                                                
      WDY-Content:  FITV_POWL_TRIPS.POWL                                                                                
      WDY-XContent:3C3F786D6C2076657273696F6E3D22312E30223F3E3C436F6D706F6E656E74204E616D653D22504F574C5F55495F434F4D502220436F6E6649643D224
      64954565F504F574C5F54524156454
      WDY-Content-Type:

      Edit: WD4A Customizing works with every other aplication I tried... Travel Request, Travel Expenses, LEA, anything... just not with the one I need....

      Edit: I'm now looking for a way to enhance Feeder Class CL_FITV_POWL_FEEDER_TRIPS to eliminate tabs "My Travel Plans" and "Credit Cards"...

      Edit: I enhanced all methods of CL_FITV_POWL_FEEDER_TRIPS on trial and refreshed all possible changing parameters to inflict as much damage as possible on the POWL WD4A, hoping it would affect the tabstrips. It didn't. I killed pretty much everything except the tabstrips I want to be invisible.... I'm going to reverse all this now and try to delete the respective POWL-Queries in IMG... this is my last idea...

      Edit: IT WORKED!! I deleted the respective table entries from TA POWL_QUERY. The Tabs are finally gone! Good grief. Points given to all who tried to help :-|

      Edited by: Lukas Weigelt on Feb 17, 2011 1:39 PM

      Edited by: Lukas Weigelt on Feb 17, 2011 2:28 PM

      Edited by: Lukas Weigelt on Feb 17, 2011 4:17 PM

      Edited by: Lukas Weigelt on Feb 17, 2011 4:31 PM

  • Feb 14, 2011 at 11:51 AM

    Maybe you need to activate the changes again in 103 also.

    thanks

    sarbjeet singh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 16, 2011 at 05:02 PM

    Lukas, we had a similar phenomenon and finally figured out, that the user had made a personalization.

    There are these three levels of changing the UI in Web Dynpro:

    1. configuration

    2. customization (that is what you have done with configurationId=X

    3. personalization

    You can undo personalization in the web dynpro application directly, check the context menu \-> User Settings

    However, this is just a guess :-).

    Online Documentation on this topic: http://help.sap.com/saphelp_nw70ehp1/helpdata/en/47/bbbeac2b07296fe10000000a42189b/frameset.htm

    Add comment
    10|10000 characters needed characters exceeded