Skip to Content
author's profile photo
Former Member

PROTCONV crashes every Monday morning


I've the problem on my SLES10 with MaxDB that the tool protconv every monday at ca. 04:30 crashes with segfault. The only reason I know this, is our monitoring system wich alerts the following text from /var/log/messages:

Feb 14 04:26:34 hk-bhbp0 kernel: protconv[32369]: segfault at 0000000000000000 rip 00002ada01206990 rsp 00007fffaa2ed2b8 error 4

The Problem occured first time, after I had updated the DB from to Does anybody has an Idea what's happening here? If I start protconv manually the entry in /var/log/messages does not appear.

Does protconv only runs one time per week?

Thanks in advance for your answers.


Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Posted on Mar 01, 2011 at 03:45 PM


    the purpose of 'protconv' is to convert the 'pseudo-XML' error log files in /sapdb/data/wrk/ to plain text [(for details click here)|].

    Basically, protconv is used by other applications like Database Studio, Database Manager or R/3 transaction DB50 or via dbmcli whenever the log files are requested.

    I have not heard of any segmentation fault in combination with protconv, but to proceed here, I would suggest determining the application that calls protconv at 04:30. If this is an R/3 system, please check for any database jobs around that time. Also, is there any corresponding error message in the 'dbm.prt' file?



    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Thorsten Zielke


      I tried to execute on another system but did not get the segfault. Unfortunately I had no downtime for the system until now so I could'nt change the knlmsgarchive-file.

      But I tested some things and found out, that probably the switch -f (output format) in the command is the problem. I checked the two other options (plain and xml) for the switch an got no segfault.

      How the filekey (switch -t) was written, means with underscore or not, was not relevant.

      Next time I get a downtime I will try to make a new knlmsgarchive-file and check wether the protconv command will work or not.


      Norman Stoer