Skip to Content
author's profile photo
Former Member

SAP J2EE Engine 6.30 - SP04

Hi,

I am upgrading the SAP J2EE Engine 6.30 from SP02 to SP04. In order to apply SP07 from SP02, it is binding that SP04 must be applied. I have encountered an error during the phase: Deploy via SDM/J2EE, the error says:

Aug 11, 2004 10:43:22... Error: Cannot connect to database: Could not load or instantiate some required class.

Additional error message is:

java.lang.ExceptionInInitializerError

Stack trace of original error or exception is:

java.lang.ExceptionInInitializerError

at javax.crypto.Cipher.a(DashoA6275)

at javax.crypto.Cipher.getInstance(DashoA6275)

at iaik.security.provider.IAIK.a(Unknown Source)

at iaik.security.provider.IAIK.addAsJDK14Provider(Unknown Source)

at iaik.security.provider.IAIK.addAsJDK14Provider(Unknown Source)

Caused by: java.lang.SecurityException: SHA1 digest error for default_local.policy

Aug 11, 2004 10:43:22... Error: Execution of deployment action for "com.sap.engine.jddischema" aborted:

Db connect failed.

Aug 11, 2004 10:43:23... Error: Deployment NOT successful for com.sap.engine.jddischema

Aug 11, 2004 10:43:23... Info: SDM configuration: Do not automatically start/stop J2EE Engine. Do not restore state of J2EE Engine now.

Aug 11, 2004 10:43:24... Error: -


At least one of the Deployments failed -


Aug 11, 2004 10:43:24... Info: Summarizing the deployment results:

Aug 11, 2004 10:43:24... Error: Aborted: /temp/sapcd/J2EE/J2EE-SP04/J2EE-RUNT-CD/J2EE-ENG/JDD/J2EE_JDDSCHEMA.SDA

Aug 11, 2004 10:43:24... Error: Admitted: /temp/sapcd/J2EE/J2EE-SP04/J2EE-RUNT-CD/J2EE-ENG/JDD/SYNCLOG.SDA

Aug 11, 2004 10:43:24... Error: Admitted: /temp/sapcd/J2EE/J2EE-SP04/J2EE-RUNT-CD/J2EE-ENG/JDD/COM.SAP.SECURITY.DBSCHEMA.SDA

Aug 11, 2004 10:43:24... Error: Admitted: /temp/sapcd/J2EE/J2EE-SP04/J2EE-RUNT-CD/J2EE-ENG/JDD/XML_DAS_SCHEMA.SDA

Aug 11, 2004 10:43:24... Error: Admitted: /temp/sapcd/J2EE/J2EE-SP04/J2EE-RUNT-CD/J2EE-ENG/JDD/JMS_JDDSCHEMA.SDA

Aug 11, 2004 10:43:24... Error: Processing error. Return code: 4

I tried to individually deploy the above SDA'e via SDM-startSDM.sh and I get the error:

Db connect failed.

If you install the SAP J2EE Engine 6.30 from CD without applying any support packages. Can you directly apply SP07? Does it work like that. Since 630 and 640 are the same version but different SP levels.

Any thoughts or ideas would be really appreciated.

Sincere Regards,

Buddha

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • author's profile photo
    Former Member
    Posted on Aug 11, 2004 at 05:11 PM

    Hi Buddha,

    it's hard to say if this will work definitely, but as far as i observed, at least SP5 and 6, although declared as binary patches, contained the complete server core.

    I installed SP5 and SP6 over a non patched base reinstallation which i had to do because of severe PC problems on two different PCs. And always ALL SDAs/SCAs have been updated after that.

    Now, since your current SP02 installation seems to be in an undefined state now anyway, i suggest to try to upgrade to SP7 directly from this.

    Good luck and regards,

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Stefan and Everyone,

      I have solved my problem. Just want to let everyone know if u have to install the SP's for WEB AS 6.30/6.40.

      You start from the installation from CD 6.30/6.40. Everything will be working at this point. You can login to Visual Admin, Config tool and SDM.

      Before you apply any SP's, do the following:

      a) Create an emergency user with the Administrator rights: Ref OSS Note:669848

      Try to follow this route for SP's:

      From CD 6.30/6.40 -> SP04 -> SP07

      Apply SP04 first before applying SP07 (Recommended Approach).

      Refer the installation guide: SAP Web AS Support Package Guide 630SP2 to 640SP4.

      Use JDK1.4.2_05 to install SP04. You must reference the following OSS Notes and apply to your system accordingly, this is the key to an error free installation:

      a) OSS Note: 697535

      b) OSS Note: 709140

      c) OSS Note: 716604

      d) OSS Note: 706378

      You have to be really careful with SP04 installation, because it changes the version from 6.30 -> 6.40.

      Once you are able to install SP04 without any problems, you can directly apply SP07 or the highest 6.40 SP.

      Kind Regards,

      Buddha.

  • author's profile photo
    Former Member
    Posted on Aug 11, 2004 at 11:18 PM

    Hi Stefan,

    I started the SP07 install. The funny thing is that the installation stops at the same point where it did for SP04. I don't understand this point in the error and this is where the error starts:

    Info: Creating connections to database "DE1".

    Error: Creation of DataSource for database "DE1" failed

    There is no database DE1. DE1 is the <sid> of the Central Instance with user:de1adm.

    The database instance id is: AS1 with user: oraas1.

    I don't know why it is attempting to connect to 'DE1'

    I don't know if it is the path/env problems.

    Kind Regards,

    Buddha.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Aug 19, 2004 at 01:28 PM

    Hi Tom,

    I am at Oracle 9.2.0.4.

    Regards,

    Buddha.

    Add comment
    10|10000 characters needed characters exceeded