Skip to Content

SAP MI 2.5 (+CrEme) doesn't work under Windows Mobile 2003 Second Editon

While testing our new Hardware (Dell Axim X30 with Intel PXA270-CPU and Windows Mobile 2003 Second Edition (4.21.1088)) i noticed, that the SAP MI Client Software will not work at all!

<i>Setup says "The program you have installed may not display properly because it was designed for a previous version of Windows Mobile software."

But this doesn't seam to be the Problem, because whenever you install an application that hasn't been updated to be compatible with the Second Edition, this dialogue box pops ups.</i> (Reason: The new Landscape-Mode - Our device runs in Portrait-Mode)

...Ok, after tabbing "OK" at this Dialogue, Setup continues! Same procedure at the CrEme-Installer!

After Soft-Resetting, the PocketPC shows up the Message that CrEme is starting up, but it doesn't listen it's Port on the PDA!

You get a Timeout when trying to load the MobileInfrastructure via the Link at Startmenu.

Also the InternetExplorer crashes when opening a webpage with an Java-Applet. Don't know if IE crashes on Windows Mobile 2003 First Edtion, but i don't think so...

<i>Of course the SAP MI 2.5 works on the First Edition!</i>

Anyone knows this problem <b>and when can we expect a Solution?</b>

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Aug 13, 2004 at 04:51 PM

    Hi all!

    I found out that CrEme crashes after executing on Windows Mobile 2003 2nd Edition!

    Just start the CrEme-Console ("\Windows\CrEme\bin") and type "java" into the Console, it crashes immediately after printing some Messages.

    The window disappears too fast to guess what it says...

    BTW: On PocketPC 2003 (1st Edition) it doesn't crash!

    So it seams we need a new CrEme (or other VM??) for Windows Mobile 2003 2nd Edition!

    Any ideas?

    Thanks in Advance,

    Markus

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Aug 16, 2004 at 10:10 AM

    Hi Markus,

    in order to run SAP Mobile Engine on Dell Axim X30 you have to use file <b>CrEme324_ARM_CE4x_PPC_minimal</b>.CAB for the mobile client.

    The x-scale version doesn't work.

    Best regards,

    Dominik

    Add comment
    10|10000 characters needed characters exceeded