Skip to Content
0
Former Member
Feb 10, 2011 at 09:54 PM

SAPB1 error: (-8003) OBServer DLL Version Mismatch

147 Views

Hi

I'm aware that this issue has been raised before, but I'm still struggling to understand how to fix this.

On my laptop I'm running the following:

Magic Software iBOLT Suite 3.2 SP2

Microsoft SQL Server 2008 R2

SAP Business One 8.8 (8.80.237) PL: 19

The remote server is running the following:

Microsoft SQL Server 2005

Business One 2007 A (8.00.181) SP: 00 PL: 47

When I attempt to connect to Business One 2007 A (8.00.181) SP: 00 PL: 47, via iBOLT, on the remote server it returns the "OBServer DLL Version Mismatch" error. Even though I specify that the DI API Version I'm connecting to is 2007.0

I've tried unregistering SAPbobsCOM88.dll and tried registering SAPbobsCOM2007.dll, but none of this has helped.

I've tried uninstalling the 8.8 DI API and reinstalling the 8.8 DI API; I've also tried rerunning Upgrader Common.

Is it absolutely not possible to connect to Business One 2007 A (8.00.181) SP: 00 PL: 47 remotely if I'm running SAP Business One 8.8 (8.80.237) PL: 19 locally? This doesn't seem like a very efficient way of doing development, as I will need to exactly match my local environment to every single client's remote environment whenever I need to do any development.

I will also post this with iBOLT support, but it sounds more like an SAP issue.

Could somebody please assist?

Many thanks,

Carl