Skip to Content
author's profile photo
Former Member

Cannot create client error with sample SAP JCO code


I am encountering the following error when trying to connect to a R/3 system using the WAS 6.40 on my laptop. I have cut and pasted the Example1 code from the SAPJCO into my NetWeaver developer studio IDE.

java.lang.UnsatisfiedLinkError: no CpicNative in java.library.path

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)




at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)






Cannot create client, error message:

java.lang.NoClassDefFoundError occured:


I have a system user defined in R/3 but still this isn't working. I am new to Java so any light you could shed would be greatly appreciated.

Cheers and TIA,


Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Posted on Aug 10, 2004 at 05:54 AM

    Hello Richard,

    I think you should try to compile the first on the command line to lock out any influences by the developer studio. Important is, that the actual Directory (.) is in your CLASSPATH environment variable.



    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      The unsatisfied link error should be because sapjco.jar cannot link to the sapjco.dll.

      I tried to simulate the problem by

      1) Opening a java perspective.

      2) Create a new 'java' project.

      3) Add libraries sapjco.jar from the path <Drive>:\Program Files\SAP\JDT\eclipse\plugins\\lib

      You will see sapjcorfc.dll in this path

      4)Add a new class file ,Wrote a sample jco code and executed and it worked..

      The key is to have the sapjcorfc.dll in the same directory as sapjco.jar

      I hope this helps