Skip to Content
avatar image
Former Member

SAP Cryptographic Library prerrequisites ehp erp

Hello experts,

I have operative system windows x64, AN ERP 6.0 with Netweaver 7.0

Following the ehpi installation guide to up the ERP to EHP5, i read this text in prerrequisites!

{quote

You make the required preparations for a system that is secured by SAP Cryptographic Library [page 52]

If you use the SAP Cryptographic Library to secure your system, you have to download the library manually and put it into the download directory. If the library is not available, the system cannot start in the STARTSAP_NBAS phase.

Procedure

Download the latest SAP Cryptographic Library archive from SAP Service Marketplace and put it into the download directory

NOTE: If you do not put the latest version of the SAP Cryptographic Library, the upgrade program uses the already installed version of the SAP Cryptographic Library.

During the Extraction roadmap step, the enhancement package installation program checks the manifest file that is included in the SAP Cryptographic Library and decides whether the library is suitable for the system.

If the library is not the correct one, an error message appears in the checks.log file. You can repeat the failed phase after you have provided the appropriate SAP Cryptographic Library.

Additionally note 1302772 about EHP implementation says:

Due to problems with the format of the SAP Cryptographic Library

(SAPCryptolib) files from SAP Service Marketplace, the SAP Enhancement Package Installer is currently not able to update the SAP Cryptographic Library (SAPCryptolib). However, the SAP Enhancement Package Installer can take over the existing SAPCryptolib. To do so, you have to copy the file sapcrypto.lst to the directory /usr/sap/ <SID>/SYS/exe/run. The file sapcrypto.lst is included in the SAPCryptolib archive that you can download from SAP Service Marketplace.

{quote}

I havenu00B4t find the SAPcryptolib in any place in marketplace

THen the questions are:

1. How can i check my current release of SAPCryptolib....

Note: i dou00B4nt have the path mentionated in the note, i have the following path and in that directory i don't see SAPCryptolib file D:\usr\sap\QN2\SYS\exe\nuc\NTAMD64

and second question.

2. How can i fulfill the requirement of update sap crypto library to latest version?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Feb 09, 2011 at 07:26 PM

    Hi,

    >

    > 1. How can i check my current release of SAPCryptolib....

    > Note: i dou00B4nt have the path mentionated in the note, i have the following path and in that directory i don't see SAPCryptolib file D:\usr\sap\QN2\SYS\exe\nuc\NTAMD64

    >

    You can check your current release of SAPCRYPTO in changelog.txt file in your kernel where sapcrypto is installed.

    >

    > and second question.

    > 2. How can i fulfill the requirement of update sap crypto library to latest version?

    For latest version, you can refer SAP notes 1375378 and 455033.

    Thanks

    Sunny

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      If you will go through SAP note 1375378 and then under one section they have mentioned files for different platforms. so, just whether these files are present in your kernel directory or not.

      Thanks

      Sunny