Skip to Content
0
Feb 09, 2011 at 01:24 PM

SAP CI on Solaris Cluster 3.2 AMDx86

28 Views

Hello,

we migrate from HPUX to Solaris10 x86. On HPUX we run the SAP ERR6 ABAP only on NW7.0 in MC Serviceguard Cluster with Oracle as Database.

On Solaris we use SolarisCluster 3.2. We are know almost at the End with or testsystem HUX on Solaris.

Logicalhostname, Oralcelistener and oracleServer are runnig in HA Cluster. The SAP System starts on both nodes if i start it as <sid>adm, my configered resorce with Type SUNW.sap_ci_v2 starts the SAP System but can not verify that it is startet and ends up with status startup failed after a few minutes.

Under /var/tmp i found a logfile wscon-\:0-4Jai9b

there is the sap startup logged

.

.

Could not open the ICU common library.^M

The following files must be in the path described by^M

the environment variable "LD_LIBRARY_PATH":^M

libicuuc.so.30, libicudata.so.30, libicui18n.so.30 [nlsui0.c 1557] pid = 17689^M

Could not open the ICU common library.^M

The following files must be in the path described by^M

the environment variable "LD_LIBRARY_PATH":^M

libicuuc.so.30, libicudata.so.30, libicui18n.so.30 [nlsui0.c 1557] pid = 17695^M

Could not open the ICU common library.^M

The following files must be in the path described by^M

the environment variable "LD_LIBRARY_PATH":^M

libicuuc.so.30, libicudata.so.30, libicui18n.so.30 [nlsui0.c 1557] pid = 17702^M

:

the environment variable "LD_LIBRARY_PATH":^M

libicuuc.so.30, libicudata.so.30, libicui18n.so.30 [nlsui0.c 1557] pid = 25911^M

These files are located unter /usr/sap/HUX/SYS/exe/run

huxadm> ls -l /usr/sap/HUX/SYS/exe/run/libic*

-rwxr-xr-x 1 huxadm sapsys 8560944 Dez 10 20:52 /usr/sap/HUX/SYS/exe/run/libicudata.so.30

-rwxr-xr-x 1 huxadm sapsys 1708232 Dez 10 20:52 /usr/sap/HUX/SYS/exe/run/libicui18n.so.30

-rwxr-xr-x 1 huxadm sapsys 1430936 Dez 10 20:52 /usr/sap/HUX/SYS/exe/run/libicuuc.so.30

huxadm> echo $LD_LIBRARY_PATH

/usr/sap/HUX/SYS/exe/run:/oracle/client/10x_64/instantclient

The LD_LIBRARY_PATH Variable is correct set for user huxadm

Does anyon know if i have to set for user root also the LD_LIBRARY_PATH?

Or what else causes this problem?