Skip to Content
avatar image
Former Member

Cannot authenticate JCE framework

I have developed to iView component that have to connect to EAI system using external libraries called WEBMETHOD and Entrust. I have added all required libs to PAR file then test on Tomcat,work fine. But when I deplyed to EP6 and test, it got the error as below:-

Caused by: java.lang.ExceptionInInitializerError: java.lang.SecurityException: Cannot authenticate JCE framework: java.lang.SecurityException: The JCE framework contains at least one unsigned class file -- iaik/asn1/a.class

at com.entrust.toolkit.security.provider.JCEVerifierImpl.a(Unknown Source)

at com.entrust.toolkit.security.provider.JCEVerifierImpl.verifyJCEJar(Unknown Source)

at com.entrust.toolkit.security.provider.Entrust.(Unknown Source)

at com.wm.app.b2b.client.BaseContext.(BaseContext.java:109)

at com.cccc.crmep.PlanningBoard$PlanningBoardDynPage.connectWM(PlanningBoard.java:344)

Is it the security conflict between Entrust and SAPSecurity? Please tell me what should I do? Thank you in advance.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 04, 2004 at 11:54 AM

    You have to obtain a signed version of your JCE - I assumed you're using 1.4.x jdk.

    In IAIK provider, it would be a "jce_full_signed.jar".

    More info about this and similar problem you'll find at:

    http://jce.iaik.tugraz.at/products/01_jce/index.php

    regards,

    Artur

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 04, 2004 at 12:33 PM

    Thanks, Artur

    Actually on Tomcat I use jdk1.3.1,PDK5 and JCE1.2.2 from SUN. The component works fine. But on EP6, it uses another JCE called iaik_jce.jar. Is it possible that iaik_jce.jar which come with EP6 is not signed version?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Artur,

      Thanks for your advise. I managed to get it work already.

      I used the WEBMETHOD lib version unsigned, so it can work fine with iaik_jce.jar unsigned on EP6.

      Anucha