Skip to Content
avatar image
Former Member

OS06/ST06/OS07n Missing CPU and Pagging Information

Hi!

In a SAP NW 7.0 running on Windows 2003 server I'm not able to see CPU and paging detail on OS06/ST06/OS07n.

At operating system level I've cheked if the information is being collected using "saposcol -d" and then "dump cpu" but it simply doesn't deliver any information. I've tried to update SAPOSCOL but still doesn't work. I don't have any errors in EventViewer and dev_coll.

I've checked SAP note 688131 but everything is OK.

Do you have any hint?

Cheers,

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Feb 06, 2011 at 08:36 PM

    What does ST22 and SMGW have to say about this?

    Cheers,

    Julius

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      External server programs are not known to be well documented, and personally I find the application coding which executes them to be informative...

      Check the joblogs in SM37 and the dev trace in ST11, but SMGW and ST22 would be my first port of call.

      SMGW must be able to give you more infos and a retun code / error to search further on if you execute it from SM69.

      Cheers,

      Julius

  • Feb 07, 2011 at 02:07 PM

    Hello,

    Please try a reboot of Windows to clear any shared memory.

    Also check in Windows services account running saposcol is

    sid<adm> which is also a member of local admins on the server

    If you need to change this reboot Windows.

    Please try start/run perfmon check if os information is displayed OK.

    regards,

    John Feely

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 06, 2011 at 05:41 PM

    Hi,

    I've the same problem with the SAPOSCOL of two application servers running ERP 6.0 EHP4 on windows; SAPOSCOL of central instance shows all data; SAPSOLCOL of application servers does not show CPU and paging info.

    Any idea to solve it ?

    Thanks.

    Maurizio Manera

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      please go to ST06 press "Status" and check the Version of the running SAPOSCOL.

      "Collector Versions" running and dialog should be the same.

      The saposcol should be the newest Version! Remember that it is downwards compatible.

      If a restart of the Hostagent does not resolve your problem, stop it, and try to clean up /usr/sap/prfclog. Check the output in dev_coll.

      Kind regards

      Manuel

  • avatar image
    Former Member
    Dec 12, 2011 at 06:16 AM

    Hi,

    from saposcol dialog, clean the memory then reattach the shared memory and check if it shows, you can try this.

    saposcol>clean

    saposcol>kill

    saposcol>leave

    saposcol>launch

    Then check if it shows CPU data.

    check for further log in dev_coll if any thing is there.

    Thanks,

    Balaji.s

    Add comment
    10|10000 characters needed characters exceeded