Skip to Content
0
Former Member
Feb 04, 2011 at 10:26 PM

Problems displaying CR Viewer when using VS2010

16 Views

When I try to display a form containing reference to a CR Viewer I get the following error message:

*An error occurred creating the form. See Exception.InnerException for details. The error is: The type initializer for 'CrystalDecisions.Shared.SharedUtils' threw an exception.*

Other info: Win7 Pro 64 is operating system. Installed Beta 2 of CR last August and was able to upgrade old CR (Ver 8.5) reports and to display reports albeit by a rather convoluted process. I created a seperate form for each report, added the viewer, showed the form which then displayed the report. To display form showing report the code line = "frm_cr_rpt01.show"

RECENTLY installed CR13 and this is when the problems started. I can no longer call up the previously running 'report' forms as I get the same error as above. I have tried adding the CR viewer directly to the 'calling' form and displaying the report with code line= "me.cr_rpt01.printreport" (similar to the process used in VB6) and get the same error.

I can open the CRreport.rpt in solution explorer and data and all report formatting displays just fine.

Suggestions anyone?