Skip to Content
author's profile photo
Former Member

UI API does not send any events....

Yesterday i got my addon registered (manually) at last and it was running fine for a few hours. Then SBO crashed leaving me with a message box saying:"Fatal Error in UI API. All events will be blocked."

Since i got this message, my addon does not get any messages from SBO anymore. I've reinstalled the SBO Client, restarted our SBO server, installed my addon on other PCs, but nothing helped. I've changed absolutely nothing in the source code. When i enter debug mode in .NET Studio i can see that code is running fine (adding menu items, opening Message Box etc.) until it get's to the message handling queue. There it stops and seems to wait for any message. The whole message handling code is a copy of the example code shipped with the SDK.

Any ideas?

Thanks in advance!

Clemens

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Posted on Jul 30, 2004 at 01:15 PM

    I have seen a similar problem on a customers machine (client, not server) where the events weren't coming through to the add-on. This turned out to be caused by old business one files being left behind on the machine from an old evaluation copy that had been uninstalled. It appeared that although uninstalled, it left some bits behind. I manually wiped all the business one files from machine - program files, TEMP, system directory. Luckily I didn't need to go near the registry. After this re-installing everything fresh worked fine.

    If it isn't that, here are a few other questions / thoughts:-

    Is the message handling code you refer to the "Do While GetMessage" loop from the sample code?

    Does it work if you launch it from visual studio, and only fail if you have it auto-starting with business one?

    Does the standard "CatchingEvents" sample work ok?

    How did you register it "manually"?

    Have you included "withevents" on SAPbouiCOM.Application ?

    Have you used any event filters that might be preventing events from getting to your application?

    Have you tried running the event monitor (double click the green monitor in the system tray) - see if it is detecting any events.

    Have you got the correct versions of SAP Business One.exe, SAPbouiCOM.exe, OBServer.dll and SBOAddonReg.dll?

    Delete any old files lying around in TEMP\SM_OBS_DLL

    John.

    Add comment
    10|10000 characters needed characters exceeded