Skip to Content
avatar image
Former Member

Problem Consuming Web Service

Hello, I have a question regarding consuming a Web service in NetWeaver. I am very new to NetWeaver but have experience in Java (J2EE) and Web services in general. I'm using the 6.4 trial version of the WAS. What I'm trying to do is create a Client Proxy Definition (from a Deployable Proxy Project)using a locally saved WSDL file. After I select New -> Client Proxy Definition I fill out all the relevant information in the dialog (package, proxy name, wsdl source - local file). Next I select the WSDL file and use the default packages for the xml namespaces. I then select Finish which (after some processing time) brings up an error dialog that says "Problems while generating the Proxy Definition!".

Can anyone tell me how I should go about debugging this problem? The error dialog doesn't shed any light on what the problem is and I'm not sure where I should be looking for log files or such. I feel confident that the WSDL file is fully compliant with the 1.1 WSDL specification as I have used the same file successfully with tools like Apache Axis and XML Spy. Any help on this problem would be appreciated.

Thanks,

Corey

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jul 29, 2004 at 07:31 PM

    Hi Corey,

    the log is saved in your current workspace. There should be a folder ".metadata" containing a file ".log". This should (hopefully) contain more explanations why the import respective client proxy generation failed.

    Please have a look at it and (if there's anything) post it here.

    Hope that helps.

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded