Skip to Content
0
Former Member
Jan 31, 2011 at 01:26 PM

OsoftMetaDataExt COM object removed during patch installation

16 Views

I have a customer using Windows 2008 R2 as the front-end BPC server. BPC 7.5 SP4 installs fine with no problems. We have both Application Sever and IIS roles installed.

If we then try to install either patch 3 or patch 2 (tried patch 3 first), the OsoftMetaDataExt COM+ object is removed. I note that in the patch installation log, this COM+ object is mentioned as one that is being installed. There are no error messages, but after the patch is finished installing, the server manager diagnostics show it as missing, as does the COM Object explorer in the OS.

I tried manually registering the OsoftMetaDataExt.dll file using the x86 version of the GACUTIL.exe (from the dot net 2.0 SDK). This seemed to install it, and I was able to list it with the utility. But, still does not show up in the COM object explorer and server manager still shows it as missing. would it possibly be necessary to use the x64 version instead?

My qeustion is: Is there a known situation or setting where this would fail to be installed? Also, what is the proper steps to try to manually install it?

Right now we are reverting to SP4 with no patches (again- this works fine).

thanks for any insite on this one.