Skip to Content
avatar image
Former Member

How to disable INPUT in field of control table ?

I'm looking for a way to disable input for some fields in my control table, in my new dynpro.

I read some subjects on this, but it doesn't work in my case, with attribute active / Input and other ...

So in my PBO I have my module tc_afs_coul_giv_change_tc_attr :

MODULE tc_afs_coul_giv_change_tc_attr OUTPUT.

SELECT * FROM zafs_coul_giv INTO CORRESPONDING FIELDS OF TABLE it_zafs_coul_giv WHERE matnr = rmmg1-matnr.

REFRESH CONTROL 'TC_AFS_COUL_GIV' FROM SCREEN '9005'.

DESCRIBE TABLE it_zafs_coul_giv LINES tc_afs_coul_giv-lines.

LOOP AT SCREEN. "SLE TEST IF sy-tcode = 'MM03'.

* IF screen-name = 'WA_ZAFS_COUL_GIV-ZZREGR_COLOR'." OR screen-name = 'WA_ZAFS_COUL_GIV-ZZSTORY'.

screen-active = '1'.

screen-input = '0'.

* ENDIF.

But it doesn't work... every field are able ton input !!

In debug mode, my screen-input is well equal to 0, but it's displayed as input ...

WA_ZAFS_COUL_GIV is my structure in my control table.

I want my fields disabled when i'm in 'MM03'

I spent my day on this problem, so i'm asking for some help


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers