Skip to Content
avatar image
Former Member

Single-Sign-On Error between Portal DEV Box and SAP DEV Box

First off I am new to the Portal (we are using version 7.0 SP5). I went into System Admin, system landscape and added a new system (to point to our SAP DEV box. When I right-click on the system name and choose Open, Connection Tests, and perform both tests (ITS Connection & Connection Tests for Customers) the first test passes but the 2nd test fails. Here are the findings for the 2nd test:

Test Details:

The test consists of the following steps:

1. Retrieve the default alias of the system

2. Check the connection to the backend application using the connector defined in this system object

Results

Retrieval of default alias successful

Connection failed. Make sure that single Sign-On is configured correctly.

I went into Keystore Administration, and downloaded the file (from the Portal)

I then went into our SAP DEV system and ran SSTRUSTSSO2 and imported the ticket.

What step(s) did I miss to get this to work correctly?

Please be as detailed as possible as we do not have a bsis person.

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 06, 2011 at 10:58 AM

    Hi,

    I recommend you run the SSO2 wizard from note 1083421 to insure your certs and configuration are ok.

    Regards,

    Cathal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 30, 2011 at 01:40 PM

    Hi,

    In the system administration -- ume, please make sure that you had selected ur R/3 system as reference system.

    An this requires a restart of the system to get effected.

    Regards,

    Phani

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2011 at 01:07 AM

    Under Sys Admin, UME Configuration, User Mapping, we DO have the Reference System = SAP_R3.

    Any other suggestions???

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Thomas,

      Ensure you are checking the Conncetion tests with a user that exists on the backend system too... ie., There needs to be a common user ( same user ID) on both the portal and the ABAP backend system for SSO to parse through.

      The steps you have performed for configuring SSO seem fine to me. Hope this helps.

      Also, in User Management drop down in portal-> System Administration-> System configuration->System, ensure option "admin, user" is selected.

      Have you added the certificate to both Add to Cert list and Add to ACL?

      Rgds,

      Soujanya

  • avatar image
    Former Member
    Jan 31, 2011 at 10:22 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2011 at 03:50 PM

    I am running the connection test under my own id, which does also exist in the SAP R3 system.

    Regarding: "...in User Management drop down in portal-> System Administration-> System configuration->System, ensure option "admin, user" is selected." Where is this path you are referring to? I looked in System Admin, System Config, System landscape but am not sure where the User Management piece is that you are referring to. Can you pelase clarify where I find the "admin, user" piece is that you are referring to?

    Have you added the certificate to both Add to Cert list and Add to ACL? I only added it to ACL, should I add it to the certificate list as well?

    Thanks for your help!!!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello,

      Yes, you need to add the portal certificate in 000 client of the ABAP system. For this seelct option Add to certificate list in strustsso2.

      The admin,user entry can be found in portal.. System Administration->System configuration-> <your system created>, right click-> Properties-> User management-> Admin, user in last field drop down.

      Hope this helps.

      Rgds,

      Soujanya

  • avatar image
    Former Member
    Feb 15, 2011 at 11:47 AM

    Don't forget to add the imported Portal certificate to the ACL in STRUSTSSO2.

    To get detailed error messages, start Tx. SM50 and set trace level to 3 for security. Reset trace file, reproduce the problem and look at the trace file.

    Please post the results.

    Add comment
    10|10000 characters needed characters exceeded