Skip to Content
0

HCPms push problems

Dec 09, 2016 at 02:07 PM

45

avatar image

Hi Guys

I am having a lot of trouble getting HCPms push to work reliably, I set it up previously on a trial instance and it worked fine. Now i have set it up on our regular HCP instance and i am having a lot of issues.

Once in a while a few notifications get through, but it pretty much does not work. I have tested push directly to Apples service and they come though fine.

The response from the server looks fine:

{ "status": { "value": "OK", "code": 0 }, "notificationId": null, "results": [ { "status": { "value": "OK", "code": 0 }, "registrationId": "23e16a94-ea5f-4bbb-bb8f-c5a841e6c5b3", "notificationId": "930497a0-b378-49c7-98f5-4a7941a9589d" } ] }

And when .i look in the HCPms log there are no errors. If i turn the log level all the way up i get these every once in a while:

#2.0#2016-12-09 09:08:07 PM#ALL####Push#1481314087891000#c21d8683-af06-49f7-bf5b-bb4efd397615##com.sap.mobile.platform.server.notifications.async.impl.DispatchRunnable:run########90236#####Skipping dispatch for tenant d0bc9fdb-3bfa-41f3-a751-d8f18ce728fd. Delay not yet reached#

Occasionally i will get a log with type "Notification" with a long trace but no obvious errors.

Any help will be greatly appriciated!!

Edit - After looking around a bit and trying out the preview version of HCPms i found a repport that shows the status of push messages. It turns out that i have 6 succesful and 40 errors! But the log shows zero errors. Obviously something is going wrong and the system even knows about it. But actually getting to those errors dosen't seem possible.

Best regards

Olav

10 |10000 characters needed characters left characters exceeded

Hello Olav,

I would suggest you to reach out to SAP support by raising an OSS ticket.

Regards,

JK (Moderator)

0
* Please Login or Register to Answer, Follow or Comment.

0 Answers