Skip to Content
avatar image
Former Member

TSV_TNEW_BLOCKS_NO_ROLL_MEMORY or TSV_TNEW_PAGE_ALLOC_FAILED

Hi;

Our SAP servers run on Windows Server 2003 Enterprise x64 Edition and Mssql 2005 64 bit. They have 16 Gb Ram and 42 Gb virtual memory.

I have to make system measurement by using tcode USMM. Although there is no problem when i run USMM on our test and productive server, i get a short dump TSV_TNEW_BLOCKS_NO_ROLL_MEMORY or TSV_TNEW_PAGE_ALLOC_FAILED when i run USMM on our development server. I have checked profile parameters. They seem same on all servers. We get the dump only at our development server.

We have upgraded our production and test systems after that we have made system copy from production to development. Only difference is that.

The details for dump is below:

Runtime Errors TSV_TNEW_BLOCKS_NO_ROLL_MEMORY

Date and Time 27.01.2011 10:53:44

Short text

No roll storage space of length 1765392 available for internal storage.

What happened?

Each transaction requires some main memory space to process

application data. If the operating system cannot provide any more

space, the transaction is terminated.

Error analysis

The internal table "\PROGRAM=RSUVM000\FORM=INIT_SYSTEM_DATA\DATA=SYSTEM_DATA[]"

could not be enlarged further.

Memory location: "Session memory"

You attempted to extend the data structure for the management of the

memory blocks for table "\PROGRAM=RSUVM000\FORM=INIT_SYSTEM_DATA\DATA=SYSTEM_DA

TA[]". However, the 1765392 bytes required for

this were no longer available in the specified memory area.

The amount of memory requested is no longer available.

-


Runtime Errors TSV_TNEW_PAGE_ALLOC_FAILED

Date and Time 27.01.2011 10:11:11

Short text

No more storage space available for extending an internal table.

What happened?

You attempted to extend an internal table, but the required space was

not available.

We have observed that a disp+work.exe is rising to 4 Gb after that system gives the dump.

Is there any advice to solve the problem?

Best regards

Noyan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 27, 2011 at 09:29 AM

    Hi Noyan,

    it seems that you get extremely more data on your development system. Internal Table SYSTEM_DATA in USMM is built using FM VCM_GET_MEAS_DATA, which calls several following FMs. E.g. one is to get data of background jobs. If you don't reorganize your data on development system, they may be available from the beginning.

    Please check, which fm call in VCM_GET_MEAS_DATA causes your problem!

    Regards,

    Klaus

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Klaus Babl

      Hi Klaus;

      Thanks for your help. We have applied the note 1525956, then we run database utility for table TUMRES (Delete data - Activate and adjust database).

      Everything seems ok now.

      Best regards

      Noyan