Skip to Content
0
Former Member
Jan 21, 2011 at 11:25 AM

No SOAP Envelope

140 Views

Hi,

First time post. New to PI. Am in the process of developing my first PI scenario. Almost works but not quite. Looking at SXI_Monitor I can see the data hitting PI and being passed from the Outbound Interface to the Inbound Interface. The last step is to consume the web service defined on the Receiver communication channel. However, when this is done I get the following error:

http://schemas.xmlsoap.org/soap/envelope/">

<SOAP:Body>

<SOAP:Fault>

<faultcode>SOAP:Server</faultcode>

<faultstring>Server Error</faultstring>

<detail>

http://sap.com/xi/WebService/xi2.0">

<context>XIAdapter</context>

<code>ADAPTER.JAVA_EXCEPTION</code>

<text>com.sap.aii.af.ra.ms.api.DeliveryException: XIAdapterFramework:GENERAL:com.sap.aii.af.ra.ms.api.DeliveryException: No SOAP Envelope but 1 definitions; HTTP 200 OK

at com.sap.aii.adapter.xi.ms.XIEventHandler.onTransmit(XIEventHandler.java:455)

at com.sap.aii.af.ra.ms.impl.core.queue.consumer.CallConsumer.onMessage(CallConsumer.java:134)

at com.sap.aii.af.ra.ms.impl.core.queue.Queue.run(Queue.java:917)

at com.sap.aii.af.ra.ms.runtime.MSWorkWrapper.run(MSWorkWrapper.java:56)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:104)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:176)</text>

</s:SystemError>

</detail>

</SOAP:Fault>

</SOAP:Body>

</SOAP:Envelope>

Have seen other threads on this on here but none have helped. As far as I can see the SOAP Action field is correctly defined and it should work.

Anybody know what the "No SOAP Envelope but 1" error is telling me ?

Cheers,

Paul Clements.