Skip to Content
author's profile photo Former Member
Former Member

Mapping and Interfacing files into R/3 as IDOCs using XI

We are trying to send an IDOC into R/3 thru XI. We generated one from R/3 into XI - it worked fine, however the reverse direction is not working well.

We are using XI 2.0 with R/3 4.6C.

We ran into two problems:

when we tried DEBMAS/DEBMAS06, we were getting a message in SXMB_MONI / IDX5 that the entry DEBMAS06 is not found (in table IDOCSYN) on XI. On our XI server we found that there were only 65 IDOC message types defined (I dont know why .. but none of the popular IDOC messages like DEBMAS, CREMAS, MATMAS, ORDERS, etc are in XI). We thought may be that is the reason. But we do not know thru config, how to add IDOC messages into XI - this is not the same as importing IDOC type .. we have already done that. Just importing an IDOC structure does not put an entry in tables like IDOCSYN, and others...

Then we tried using an IDOC message that was in XI IDOC tables - FLIGHT_SAVEREPLICA. This ones gets past the error we got with DEBMAS. However, we still do not see the IDOC in R/3. When we check IDX5 or SXMB_MONI, it says that the message is processed successfully and does not show any errors. We are not understanding why it does not reach R/3.

Has anyone mapped files into IDOCs and sent to R/3 thru XI. If you did, CAN YOU PLEASE HELP US OUT....

It looks like we are missing small config step .. somewhere ..

We created partner profiles, set up ports and RFC destinations. IN SLD we did define the logical systems. On the surface, from the config everything seems fine.

OSS note 669669 is already in.

Any help will be greatly appreciated ...

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 14, 2004 at 06:47 PM

    Hey Srini,

    Were you able to solve this problem. If yes could you please help us out we are facing the same kind of problem.

    Thanks,

    Yogesh

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 15, 2004 at 02:30 PM

    > We are trying to send an IDOC into R/3 thru XI. We

    > generated one from R/3 into XI - it worked fine,

    > however the reverse direction is not working well.

    > We are using XI 2.0 with R/3 4.6C.

    >

    > We ran into two problems:

    > when we tried DEBMAS/DEBMAS06, we were getting a

    > message in SXMB_MONI / IDX5 that the entry DEBMAS06

    > is not found (in table IDOCSYN) on XI. On our XI

    > server we found that there were only 65 IDOC message

    > types defined (I dont know why .. but none of the

    > popular IDOC messages like DEBMAS, CREMAS, MATMAS,

    > ORDERS, etc are in XI). We thought may be that is the

    > reason. But we do not know thru config, how to add

    > IDOC messages into XI - this is not the same as

    > importing IDOC type .. we have already done that.

    > Just importing an IDOC structure does not put an

    > entry in tables like IDOCSYN, and others...

    You need to change the outbound version to a lower version. ie send debmas03 not 06.

    This is an ALE to ALE issue. Not XI related.

    > Then we tried using an IDOC message that was in XI

    > IDOC tables - FLIGHT_SAVEREPLICA. This ones gets past

    > the error we got with DEBMAS. However, we still do

    > not see the IDOC in R/3. When we check IDX5 or

    > SXMB_MONI, it says that the message is processed

    > successfully and does not show any errors. We are not

    > understanding why it does not reach R/3.

    >

    Trace time....

    > Has anyone mapped files into IDOCs and sent to R/3

    > thru XI. If you did, CAN YOU PLEASE HELP US OUT....

    >

    > It looks like we are missing small config step ..

    > somewhere ..

    >

    > We created partner profiles, set up ports and RFC

    > destinations. IN SLD we did define the logical

    > systems. On the surface, from the config everything

    > seems fine.

    > OSS note 669669 is already in.

    >

    > Any help will be greatly appreciated ...

    Use SXI_SUPPORT and follow it in debug...

    Cant tell what else is wrong.

    Add comment
    10|10000 characters needed characters exceeded