Skip to Content
avatar image
Former Member

Integrating existing XI3.0 system(on JDK Version 1.4) to MS SQL Server 2008

Hi,

We are integrating existing XI3.0 system to MS SQL Server 2008. We deployed the JDBC Driver from Service MarketPlace.

Systems Involved: XQ3(XI 3.0 on JDK Version 1.4.2_09), MS SQL Server 2008

JDBC Driver: sqljdbc_12_hotfix.zip from SAP Service Market Place deployed via SDM.

Exception in Adapter Monitoring:

com.microsoft.sqlserver.jdbc.SQLServerException: The server version is not supported. The target server must be SQL Server 2000 or later.

Error in Integration Engine Monitoring : com.sap.aii.af.ra.ms.api.DeliveryException: Database connection could not be established.

Any other higher versions of JDBC Drivers cannot be installed as their deployment needs JRE 5 or higher.

Please share your ideas if anyone had faced similar issue.

Regards,

Manikandan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 20, 2011 at 10:14 AM

    Hi Manik,

    Check /people/dheeraj.kumar5/blog/2010/03/23/sql-server-2008-connectivity-with-sap-pi-70-possile if it helps.

    Regards,

    Sunil Chandra

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sunil,

      Thanks for you idea.

      We indeed followed that blog, and dowloaded the hotfix driver from Service Market Place and we deployed the same.

      Still facing the same.

      Regards,

      Manikandan R

  • avatar image
    Former Member
    Jan 20, 2011 at 12:13 PM

    XI is now able to connect to MS SQL Server 2008. We created the Driver SDA file carefully(Driver we obtained form Service Market Place sqljdbc_12_hotfix.zip , also check the SAP Manisfest format, correct it using GPFixSda.zip provided by SAPNote, and maintain the folder structure as SDM not able to locate the jars when the structure chanegs)as per How to Guide and deployed into SDM. Previoulsy, after deploying into SDM, it will give warning "File Missing:unable to find sqljdbc.jar" and now mo more warning. Thanks.

    Add comment
    10|10000 characters needed characters exceeded