Skip to Content
author's profile photo Former Member
Former Member

Problem after deploying WelcomeApplication

Hi,

After deploying and starting the WelcomeApplication imported from the example-folder I got the attached stacktrace.

Also the same stacktrace occurs if I create a very simple WebDynpro-Project (one View and a Button).

I use Netweaver 2.0.5, WebAS 6.40, W2k

Any help would be appreciated.

Georg

--- --- ---

com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: failed to created delegate

at com.sap.tc.webdynpro.progmodel.generation.DelegatingComponent.<init>(DelegatingComponent.java:51)

at com.sap.tc.webdynpro.clientserver.cal.ClientComponent.doInit(ClientComponent.java:748)

at com.sap.tc.webdynpro.clientserver.cal.ClientComponent.init(ClientComponent.java:333)

at com.sap.tc.webdynpro.clientserver.cal.ClientApplication.init(ClientApplication.java:341)

at com.sap.tc.webdynpro.clientserver.task.Task.createApplication(Task.java:181)

at com.sap.tc.webdynpro.clientserver.task.WebDynproMainTask.execute(WebDynproMainTask.java:494)

at com.sap.tc.webdynpro.clientserver.cal.AbstractClient.executeTasks(AbstractClient.java:49)

at com.sap.tc.webdynpro.clientserver.cal.ClientManager.doProcessing(ClientManager.java:239)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doWebDynproProcessing(DispatcherServlet.java:130)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doContent(DispatcherServlet.java:92)

at com.sap.tc.webdynpro.serverimpl.defaultimpl.DispatcherServlet.doGet(DispatcherServlet.java:35)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:373)

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:250)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:319)

at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:297)

at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:696)

at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:221)

at com.sap.engine.services.httpserver.server.Client.handle(Client.java:92)

at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:146)

at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionMessageListener.java:37)

at com.sap.engine.core.cluster.impl6.session.UnorderedChannel$MessageRunner.run(UnorderedChannel.java:71)

at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

at java.security.AccessController.doPrivileged(Native Method)

at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:94)

at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:140)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)

at java.lang.reflect.Constructor.newInstance(Constructor.java:274)

at com.sap.tc.webdynpro.progmodel.generation.DelegatingComponent.<init>(DelegatingComponent.java:43)

... 26 more

Caused by: java.lang.NoSuchMethodError: com.sap.tc.webdynpro.progmodel.context.Node.<init>(Lcom/sap/tc/webdynpro/progmodel/context/NodeInfo;Lcom/sap/tc/webdynpro/progmodel/context/Node;)V

at com.sap.examples.welcome.wdp.IPublicWelcomeComponent$IContextNode.<init>(IPublicWelcomeComponent.java:28)

at com.sap.examples.welcome.wdp.InternalWelcomeComponent.wdInitContextNode(InternalWelcomeComponent.java:51)

at com.sap.examples.welcome.wdp.InternalWelcomeComponent.<init>(InternalWelcomeComponent.java:91)

... 31 more

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 28, 2004 at 09:58 PM

    Hi,

    Give a try by rebuilding the project, then by Deploying the new archive.

    Also please check in your Visual Administrator, whether the app is running.

    Thanks and Regards,

    Sam Mathew

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 29, 2004 at 10:19 AM

    Hi Georg,

    you have to make sure that your DeveloperStudio and the Server you are deploying to have the same PatchLevel, in your case SP5. I guess you didn't apply SP5 to your Server as well?

    Regards

    Michael

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.