Skip to Content
author's profile photo Former Member
Former Member

Error deploying FlightList Project

Hello:

I have imported the FlightList sample application. I can create an archive, but when I go to Deploy the project, I get the following error:

TutWD_FlightList.ear -> Successfully created a temporary copy

Jun 27, 2004 3:32:11 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Deploy Thread] ERROR:

TutWD_FlightList.ear -> Deployment aborted

DEPLOYMENT ...

==> SDM host : dev

==> SDM port : 50018

==> URL : file:/C:/DOCUME1/ADMINI1/LOCALS~1/Temp/1/temp31017TutWD_FlightList.ear

... ABORTED

Aborted: development component 'TutWD_FlightList'/'local'/'LOKAL'/'0.2004.06.27.15.29.41':

Caught exception while checking the login credentials from SAP J2EE Engine's deploy API:

com.sap.engine.deploy.manager.DeployManagerException: ERROR: Cannot connect to Host: [dev] with UserName: [Administrator]

Check your Login Info.

Exception is: com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: User not authorized.]

(message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.checkLoginCredentials.DMEXC)

I believe I have set-up J2EE parameters correctly in Netweaver Studio, as well as in the SLD.

Anyone have any idea's?

Also (the big also), in the Visual Administrator, I am unable to configure the SLD Data Supplier-Standard User Group to role assignment. I get "Pole Assignment Failed". However; I am able to successfully test the CIM Client Test.

Any help would be greatly appreciated.

Russ Wagner

Canada

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 01, 2004 at 01:53 AM

    Since you downloaded the whole application, I guess we can dismiss the second error about a naming problem as being caused by the initial error concerning the authorization issue. Did you change any passwords since install? I remember that Benny had commented in this forum that it was possible to get into a situation where the deployment password was out of synch. I don't recall if there was a clear way to fix it. But you might consider poking around with the steps in this link: /people/benny.schaich-lebek/blog/2004/04/13/how-to-unlock-your-java-admin maybe something will fall-out.

    Dale

    Add comment
    10|10000 characters needed characters exceeded