Skip to Content
author's profile photo Former Member
Former Member

after adding fields on KNA1 using append structure, not null dn't work

Hello, all.

let me ask you something.

after adding fields on standard table 'KNA1' using append structure, not null , default value doesn't work.

when I check table using data object check(utilities > data object > check), the report says like this.

Fld name Position Data Type Length Decimals Not null Default

MANDT 1 VARCHAR2 9 X '000'

KUNNR 2 VARCHAR2 30 X ' '

LAND1 3 VARCHAR2 9 X ' '

ZMBRN 178 VARCHAR2 30 X ' '

ZKUNNR 179 VARCHAR2 30

ZSEQ 180 VARCHAR2 12

fields ZKUNNR, ZSEQ doesn't check not null, default.

Any advice will help.

thank in advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Jan 18, 2011 at 12:54 PM

    Hello,

    your field ZMBRN has the flag "not null".

    Regards

    Dirk

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2011 at 02:08 AM

    solved by myself

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.