Skip to Content
author's profile photo Former Member
Former Member

Leave Request workflow status 'ERROR' but IT2001 updated

Dear Colleague,

We are using standard workflow 123000111 for our leave request in ESS. Leave request submitted, approved and updated in IT2001. However, workitem for the leave request is showing status u201CERRORu201D and routed to HR Administrator for processing.

Currently, as a workaround, we deleted the workitem after IT2001 updated.

If anybody has come across this issue before, please share with us possible root cause and solution.

Thanks.

Khairul

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jan 05, 2011 at 08:54 PM

    Read the note 779075.

    We dont need leave request admin step, So the WF shouldnt go to Leave request admin step, anyhow,

    if the status of the leave request is error and leave is already posted in 2001

    Then use report rptarqerr to correct teh status of these leave request which are in error read the reports documentation

    as well.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Siddharth,

      Could you please advice what is the root cause for this issue?

      How can the WF hit into ERROR while the record can be updated in IT2001?

      I wonder why the same employee who submitted 3 requests, and manager approved all in the same hour.

      2 of the requests got COMPLETED status in WF but another 1 is getting ERROR status.

      This is happening for most of the employees recently. A lot of WFs hit into ERROR.

      Should I use report rptarqerr to correct those error, and then remove application LeaveRequestAdmin using transaction SWFVISU to permanently resolve the issue?

      Thanks

      Regards,

      J_C

  • author's profile photo Former Member
    Former Member
    Posted on May 05, 2013 at 02:52 PM

    happened to me just now, Shd such kind of request be deleted in Ptarq along with deleting IT2001 record separately which got created. Also do we need to delete workflow instance manually as well. Please provide the steps to fix it.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.