Skip to Content
author's profile photo Former Member
Former Member

custom tld kills SAP J2EE Engine server

Hello all,

We've got some custom jsp tags in our J2EE application which work perfectly in tomcat. We can deploy them on the SAP J2EE Engine and everything deploys correctly. However when we load the first jsp that contains a custom tag, it completely terminates the whole SAP J2EE Engine server. There are no exception or message, the server simply dies. We are using the struts framework.

Our tld configuration is basically the same as what's displayed below:

tags.tld file contents:

<?xml version="1.0" encoding="UTF-8"?>

http://java.sun.com/j2ee/dtds/web-jsptaglibrary_1_1.dtd">

<taglib>

<tlibversion>1.0</tlibversion>

<jspversion>1.1</jspversion>

<shortname>tags</shortname>

<info></info>

<tag>

<name>myTag</name>

<tagclass>com.taglib.MyTag</tagclass>

<bodycontent>JSP</bodycontent>

</tag>

</taglib>

relevant web.xml file contents:

...

<taglib>

<taglib-uri>tags</taglib-uri>

<taglib-location>/WEB-INF/tags.tld</taglib-location>

</taglib>

...

jsp file contents:

<%@ taglib uri="tags" prefix="tagPrefix" %>

...

<tags:myTag></tags:myTag>

...

When the jsp file is loaded, this kills the server whereas it works perfectly well in tomcat. Any assistance would be appreciated.

Regards,

Stephane

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Posted on May 30, 2004 at 02:11 PM

    Which version do you use?

    Please issue an OSS message to support.

    Regards,

    Benny

    Add comment
    10|10000 characters needed characters exceeded