Skip to Content
author's profile photo Former Member
Former Member

More problems with outbound file adapter

Hello,

Can anyone please help with the error message below? What am I missing here.

Thanks !

12:45:42 (4112): File adapter listener terminated

  • Mon May 24 12:45:42 CEST 2004 *****

12:45:42 (4024): Initializing file adapter failed with

com.sap.aii.messaging.net.TransportException: HTTP Server not started, cannot proceed

12:45:42 : Error(s) in adapter configuration parameters found:

12:45:42 (4108): Unable to start file adapter (not initialized)

Add comment
10|10000 characters needed characters exceeded

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on May 24, 2004 at 12:17 PM

    and this is the config file:

    1. File adapter java class

    classname=com.sap.aii.messaging.adapter.ModuleXMB2File

    mode=XMB2FILE

    ##Adress for XMB endpoint

    XMB.httpPort=9999

    XMB.httpService=/file/file_receiver_out

    ##File Adapter specific parameters

    file.createDir=1

    file.targetDir=c:/

    file.targetFilename=xmb_output.txt

    #file.writeMode=append

    #file.writeMode=overwrite

    file.writeMode=addCounter

    file.counterMode=immediately

    #file.counterMode=afterFirst

    file.counterSeparator=_

    file.counterFormat=00000

    file.counterStep=1

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Did you check the trace log of the adapter engine if it gives you any more information? The file adapters are very picky on spelling, e.g. the error sounds like a typo or an option which the file adapter does not expect.

      I used the outbound adpater with FTP it worked ok. The only thing I have different is that I used a different port and the httpService. Further I added in the receiving business system which is not a must but helped in my case with the config.

      ##Adress for XMB endpoint

      XMB.httpPort=8214

      XMB.httpService=/file/receiver

      XMB.ReceiverAdapterForBusinessSystem=FMIMAGE

  • author's profile photo Former Member
    Former Member
    Posted on Jun 03, 2004 at 01:01 PM

    Hello Walter,

    In the adapter Engine, go to services and check if HttpServer status is "STARTED" if not please start it like any other adapters.

    Thanks,

    Rajan Kidambi

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 10, 2004 at 08:40 AM

    Thanks people for your answers!

    I found the problem....the http port was configured differently.

    Add comment
    10|10000 characters needed characters exceeded