Skip to Content

Timeout during allocate of Vertex RFC

Hi Guys.

Im facing this odd issue after an offline backup is completed and brings the system.

As you can see the Vertex RFC is no longer working and displays a timeout issue after a Sales programs tries to reach it.

Also when testing the RFC is unable to initialize.

M *****************************************************************************

M *

M * LOCATION SAP-Gateway on host etgrws01.entegris.com / sapgw20

M * ERROR timeout during allocate

M *

M * TIME Tue Dec 28 16:43:08 2010

M * RELEASE 640

M * COMPONENT SAP-Gateway

M * VERSION 2

M * RC 242

M * MODULE gwr3cpic.c

M * LINE 1854

M * DETAIL no connect of TP /boltons/D01/vertex/3.3/TransLink/verrfc from

M * host etgrws01.entegris.com after 22 sec

M * COUNTER 6378

M

A RFC 1448 CONVID 40614370

A * CMRC=27 DATA=0 STATUS=0 SAPRC=242 ThSAPECMINIT

A RFC> ABAP Programm: CL_XTAX_RULES_RFC=============CP (Transaction: VA02)

A RFC> User: VMESENBR (Client: 200)

A RFC> Destination: VERTEX (handle: 3, , )

A *** ERROR => RFC ======> CPIC-CALL: 'ThSAPECMINIT' : cmRc=27 thRc=242

Timeout during connection setup. Please check partner availability

[abrfcio.c 7933]

A *** ERROR => RFC Error RFCIO_ERROR_SYSERROR in abrfcpic.c : 1464

CPIC-CALL: 'ThSAPECMINIT' : cmRc=27 thRc=242

Timeout during connection setup. Please check partner availability

DEST =VERTEX

HOST =etgrws01

PROG =/boltons/D01/vertex/3.3/TransLink/verrfc

[abrfcio.c 7933]

That /boltons/D01/vertex/3.3/TransLink/verrfc is located on the same server as the SAP application, so i cannnot figure out why is showing partner not available/timeouts, when is pinging a program on the same server.

I have tried restarting the Dispatcher

rfc/use_gwstart =1

Increased CPIC timeout value gw/cpic_timeout =120 (Increased CPIC timeout)

I have also searched thru these notes but still no luck

Note 581509 - Reasons for timeout during allocate

Note 638701 - Starting RFC servers takes too long

Note 948636 - Starting executables locally using RFC

The only workaround for this, is restarting the SAP Application, in order to have the RFC working again, but this seems an overkill to fix an RFC Ping Issue.

All ECC Systems have the same program version and configuration but only Dev system is facing this.

The whole point of this, is why when the system is shut down in order to perform an offline backup causes this, and the only way to fix this, is shutting down/start up the system again.

If you have some ideas of what could be causing this, it's would be highly appreciated.

Martin

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jan 11, 2011 at 06:38 PM

    It was an issue with environment variables

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Martin,

      We are experiencing the same issue with SAP/Vertex. Can you let me know how you resolve this? Did you change the SAP gateway timeout parameter? If so, which one is it?

      Your help on this is greatly appreciated.

      Thanks much!

      Best regards,

      Cyanna

  • author's profile photo Former Member
    Former Member
    Posted on Aug 31, 2015 at 12:12 PM

    Hi,

    please let us know , how you resolved the error. i am facing same issue

    Thanks

    Arundhati

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.