Skip to Content
avatar image
Former Member

jnlpDownloadServlet

Hi everybody!

I just installed a WebApplicationServer and XI 2.0. I finished all installation and post-installation-steps according to the manual and the notes. But I have one problem, I couldn't solve yet:

By starting transaction sxmb_ifr my webbrowser starts as expected. It shows an overview, where I can access the Repository and so on. Every link works except for the one which should lead me to "Directory (configuration)". A new browser-window opens with following message:

Download not possible because of missing component

The download of the client software is currently not possible because

the "jnlpDownloadServlet" is probably not yet installed on the server.

Please contact your system administrator to install the component "jnlp-servlet.jar"

I don't understand this message because I included the jnlp-servlet.jar in the directory according to the manual and I inserted the according entries in the 2 files (library.txt and reference.txt)

I also included the file into the classpath of my system. Has anybody an idea what I made wrong or what I forgot to do?

Thank you very much in advance!

Greets,

Martin.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    May 12, 2004 at 03:52 PM

    Hi,

    no further questions, I fixed the problem... 😊

    Martin.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 16, 2004 at 01:09 PM

    Hello Martin,

    Can you please tell me how this got resolved we have a similar issue and also when we get the error the changes in library.txt and reference.txt are lost and even jnlp-servelet.jar gets automatically deleted in ../managers directory..

    Thanks,

    Rajan Kidambi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rajan,

      the solution of my problem was just a stupid type-error in one of the two text files (I wrote EXchange with a uppercase 'X' instead of Exchange and didn't recognize it in Notepad)... So it was not really a SAP problem.

      As I understood you, your jnlp-servlet.jar is located in .../managers. The jnlp-servlet.jar in my system is located in j2ee\cluster\server\additional-lib\jnlp-servlet.jar (this directory is also part of my classpath).

      So the only help I can give you is to check whether your entries in the .txt files are really correct.

      Hope this helps,

      Martin.

  • avatar image
    Former Member
    Jun 16, 2004 at 02:39 PM

    Hello Martin,

    Thanks for the reply, but i believe we didnt have any typo error. We were doing installation on HP-UX and i am confused why jnlp-servlet.jar gets deleted..

    any thoughts?

    Thanks,

    Rajan Kidambi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rajan,

      I just installed XI 2.0 SR1 on win2k and got the same problem.

      According to the installation guide on side 52, you just have to add the jar-file and the entries in reference.txt and library.txt. After restarting the system like discribed, the jar-file and all entries got deleted.

      Very strange...

      Any information is appreciated. I got stuck.

      Thanks,

      Mario

  • avatar image
    Former Member
    Jun 17, 2004 at 07:17 PM

    Hello Mario,

    Try OSS Note - 743630 and let me know if this helped.

    Regards,

    Rajan Kidambi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rajan,

      thank you for your response. That hint actually helped me getting the servlet registered. But I wonder why this is not noticed in any of the installation guides and notes.

      However, I finally got it work.

      Thanks again,

      Mario