Skip to Content
avatar image
Former Member

Problems configuring ssl for SAP Web AS

Hello!!

Well, I'm trying to configure my WAS 6.20 (W2K Advanced) to work with ssl. I've take the following steps:

1) First of all, I've downloaded the SAP Crypographic Library in a local directory.

2) Set the profile parameters:

icm/plugin_00 PROT=HTTPS, PLG=$(DIR_EXECUTABLE)\httpsplugin.dll (but haven't find it searching localy!!)

icm/server_port_00 PROT=HTTPS, PORT=443, TIMEOUT=120

icm/HTTPS/verify_client 1

3) I've copied sapcryptolib.dll and sapcrypt.car to the corresponding directories.

4) Generate the SSL Server PSE:

sapgenpse get_pse -p D:\usr\sap\MACHINE\SAPSSLS.pse -r D:\SAPCRYPTOLIB\CertReq1.txt "CN=server.domain.es, O=domain, C=ES"

5) I've copied the file CertReq1.txt and copy it to a CA for digital signature (PKCS #7 Format).

I've copied the one signed and paste it in a new file SignedFile.txt in the same folder that CertReq1.txt.

6) Imported the certificated:

sapgenpse import_own_cert -p D:\usr\sap\MACHINE\SAPSSLS.pse -c D:\SAPCRYPTOLIB\SigendFile.txt

It seems to be all right, but when i try to use it, SAP tells me: the port used is not configured.

I don't know much about SSL, please, help me.

Thank you very much in advance!!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • May 12, 2004 at 02:34 PM

    Hi Antonio,

    Not sure if you have done this but try the following.

    Open the Visual Admin tool for SAP J2EE Engine.

    Go to Dispatcher -> Services -> http

    In the SSL port type in 443 (or whatever port you choose for secure communication)

    Restart the http service.

    Regards

    Abdul

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks,

      the problem has disappeared without doing anything. I think that should be restarting the server how the problem could disappeared.

      Thank you very much!