Skip to Content
avatar image
Former Member

Problems when activating ComponentController

Hi experts!<br>

<br>

I am relatively new to the WebDynpro-Programming and I am facing the following issue:<br>

I have renamed one node of the component controller and I have adapted the dependant view items. When I now try to activate the component controller, the following error message appears:<br>

<br>

Message no. SWDP_WB_TOOL100<br>

Component XXX can't be generated because of errors: see long text.<br>

<br>

According to the long text, there is a heavy error and I should check the component in order to eliminate the errors. Checking the syntax is OK and strangely, the component controller is also active. But when I want to start WebDynpro-Component, the error message "Component is not active" is displayed.<br>

<br>

Has anyone an idea how to solve this issue? In the meanwhile, I have deleted the node of the component controller, but the problem is still existing.<br>

<br>

Best regards,<br>

<br>

Christoph

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jul 15, 2015 at 10:40 PM

    Hi Christoph,

    Some times,  regular  save, check and active  is not enoguth.

    When you get  Message no. SWDP_WB_TOOL100,  try  over Web Dynpro Component like show you into enclosed image. This strong verification  show you where is the error.

    Regards

    José Luis


    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2010 at 08:00 AM

    Yes such errors are difficult to find out.

    Well, i could only suggest you to check for the FM/Class Methods which are being used inside the component are activated or not?

    if not try activating the FM/Class first and then activate the web dynpro component.

    Abhi

    Add comment
    10|10000 characters needed characters exceeded